Zwift Companion App (Android) - Map cut off; issues centering map view; missing 'zoom to' icon [April 2024]

I have version 3.55.0 installed on my Samsung S10e on Android 12 and recently the map view is not centred on me and the ‘zoom to’ icon is missing. I’ve tried clearing data & cache, reboot but the same.
Attached a screenshot to show the issue.


Any ideas?

try dragging the map further away from your position and it should come back (does for me anyway)

Hi @David_Quick, thanks for the screenshot provided to better describe the issue. Besides the good workaround received. I’m attaching this article with the most common actions in-game and their descriptions. Please, review steps 3 and 4 for map view and zoom icon functionalities. Checking the screenshot provided I can see the Zoom icon is on the right side.

I would appreciate to give it a try and let us know of any updates.

Just chiming in as I have also been experiencing this issue. I can zoom in, but it still cuts off half the map. The overlay is functional (ie, I can change my watts to watts/kg), as are the buttons at the bottom, but I can not move the map around, or center it on myself - it just stays half way up, cut in half. No more ride on bombs from me…
FWIW, I have tried clearing cache, uninstall and reinstall, and confirmed the app and the computer are on the same wifi.
Any input appreciated!

1 Like

I just go to home page and re-enter game and it doesn’t happen again.

1 Like

Solution Dan mentioned works for me. Shame you have to do this to get it working, as its a work around probably wont be a high priority fix.

1 Like

Just returned to zwift after a lay-off through injury. My tablet (android 13) is displaying my arrow at the top of the screen, anyone know why.


The large red arrow?

Drag they map away so you’re not displayed and a centralizing icon will appear on the right underneath the other two icons.

Looks like crosshairs. Click that and it’ll track you in the middle of the screen.

1 Like

Tried it today on Glasgow, and it worked fine, maybe it’s just the volcano circuit that playing up, will check that tomorrow.

Hello all,

Thank you for raising this issue. We’re tracking this at HQ to be fixed in a later version. In the meantime, the workaround as provided by @Dan_Jewell_RLTW_Colo should return the map to normal behavior-

  1. Select the three lines in the top left to open the side sheet
  2. Select Home to visit the home page
  3. Repeat step 1 to open the side sheet again
  4. Select Game to return to the (now fully functional) map screen
2 Likes