Zwift Companion activity not syncing to Apple Health

I have the same problem, everything was fine until the last Zwift update this week. My last ride to sync to Apple Health from Strava was last Sunday. None of my rides from this week synced (March 9, 12, 13th) but oddly enough my run from Zwift last night (March 12) synced/flowed through without any problems.

My sync sequence is as follows → Zwift to Strava on my MacBook Air and then Strava syncs to Apple Health which then is the source for exercise activities and calories for my HealthMate (Withings) app and Noom.

I used Strava to track my Cross Country ski outing and my yoga yesterday & today and both of these activities flowed through to Health without any issues (so my downstream apps HealthMate and Noom were good).

It seems it’s only the bike rides that are having this problem. Please help!!!

Strava is no longer pushing 3rd party data to Apple Health or any other 3rd party. It’s not Zwift that has changed. It’s coincidental they happened at the same time.

If you recorded your ski in strava it will still export.

Same here!

This really is a stupid move from
Strava to exclude 3rd party activities from the sync with Apple Health. This will lead to a loss of users.

Is there any solution, that Zwift can integrate that? Would be fine, if the ZCA or Zwift could push it to the Health app directly, like it does with Strava, eventhough I am not using the ZCA on my iPhone. So as soon as I am saving my ride on my ATV, I get a message, from Strava, that a new activity was tracked. So why wouldn’t this also be possible with Apple Health?

Thanks
Paul

Hey guys,

I did a ride on Zwift just now and it uploaded to Strava okay and the data from Zwift went to Apple Health, however, the upload to Strava hasn’t synced to Apple Health, either.

Apple Health will prioritise which workout to take the data from when there are multiple sources, so ordinarily, this wouldn’t be a problem, however, Apple Health has stopped receiving the Strava data, and moreover it has stopped updating my move ring with the data from Zwift (which was my backup).

Anyone have any ideas or experiencing similar?

Many thanks
Adam

Hi. I’m having the exact same issue since the last Strava update 2 - 3 days ago :roll_eyes:

2 Likes

Really it should not be Strava that syncs it to HealthKit it should be the companion app. But this has been an issue for quite some time now Zwift Companion and Apple Health Kit - #11 by DWalton

3 Likes

Thanks guys. That’s annoying. Strava was my ’source of truth’, but I guess I’ll have to have all the various other apps send data to healthkit.

2 Likes

Yeah, this really sucks. I was reading on the Strava support that apparently with the recent Strava update they only push native Strava activity to Health now, i.e. no Zwift and others.

Using Strava as a proxy between Zwift on Apple TV and Apple heath on my iPhone (companion app) is the only way I’m aware of syncing the data (???).

There has a to be a way…and soon. I’m not going to enter all activity in health manually.

Zwift folks, help us out.

Okay, as if by magic mine just synced.

This was a Zwift ride and a Fitbod work out syncing from Strava to Health.

Okay so Strava is sending the rides to Activity via the HealthKit, however, it isn’t registering the calories etc. I’ve opened a ticket with Strava and will let you know what they say.

2 Likes

From Strava last Thursday after their latest update. Using Strava as a proxy for any 3rd party app has apparently been killed by Strava, can’t use it to sync Zwift to Apple Healther. uugghhhhh

I run Zwift on Apple TV and Companion on my iPhone so as of now there doesn’t appear to be any way to automatically pump the data into Health like there was when using Strava.

That only suggests route information won’t be sent. I guess in the meantime I should make Zwift and Fitbod (my weight training app) the priority in HealthKit for receiving data then?

This is so annoying.

To top it off, Strava is not posting my comments on their forum regarding this subject. Strava, please fix the programming error!

2 Likes

Do you @Adam_Ash or @Brad_Rolf have a link to the support thread on Strava? I find their support forum terrible to search or browse! I can see the calories pulling into Apple Health for me, under the activity, but the total Move calorie unit does not get updated. Terrible bug to introduce and not get picked up by testing.

4 Likes

In case it helps anyone, just found out the latest Strava update had turned off Strava Health syncing.
I went into the Strava app. Then to Profile | Settings | Applications, Services, and Devices.

Turned Health on there (it was off). Then went into my latest ride and pulled down to refresh it. Works ok now for me.

5 Likes

Does it update the move ring though? The rides are coming through by the rings are not updating.

Oddly it shows the calories in the workout app on phone but hasn’t added them to move ring total.

Whats even more bizarre, Fitnesspal (from Health) IS picking up the calories but the watch doesn’t…silly…

I tried to start a thread on the Strava forums and got the following:

Thanks for your recent post to the Strava community forums! To give you the best service possible given the nature of your post, we have created a direct support request on your behalf. A Strava support agent will be assigned to your ticket to assist you.

Below is a summary of your post:

My Apple Activity move rings aren’t moving after completing rides on Zwift and uploading the data to Strava. Anyone have a solution?

1 Like