Zwift Click Firmware Update stucks on Set DFU-Mode

Hi,

Yesterday I received the Zwift Hub One. I updated the Zwift Hub without any problems. After that I connected the Zwift Click to the Companion App and tried to update the firmware. But it stays on Set DFU mode and the connection of Zwift Click is lost after a few minutes. But the blue LED stops flashing and I am obviously connected to the app, otherwise I would not be able to start the update.

Does anyone have a hint as to what mistake I am making?

Thanks a lot and best regards
Mario

I had the same problem the first time I tried to update.

I closed the Android Companion App completely (App Info - Force Close) and tried again and it worked right away.

I’m curious if you will also have the watt/speed problems that occur here partly…

I had the same issue with my Zwift play controllers last week. Eventually I had to just switch them off. Fortunately, they still worked fine during following rides. That happened several times, so I stopped trying to upgrade for the week. This weekend they upgraded just fine.

Your risk, you have to make the choice, but I would say just use the click for a while if it connects and works, and try the upgrade later.

Thank you very much for your replies. I de-energized the click and reinstalled the companion app. Same result. So I wait some days and try to make the update.

I also cannot update my new Zwift Click. It also freezes at the “Set DFU mode”. The device reboots, blinks the blue light until it automatically turns off.

I already used it once on Zwift within a workout and free ride and it is functional.

EDIT: 4 days after, it updated without issues! I cannot really say what I did different in the meantime, except changing the position of the clicker on the handlebar :smiley:

I also have the same issue.
I tried many different ways to connect: different places, reinstall
On Zwift app companion it connects but stuck on DFU-Mode.
My phone can detect it but that’s it
I cannot see it on Zwift game. I cannot use it.
I wanted to send it back but I cannot find the option to only send back the click without sending the whole hub…
I am desperate

Having exactly the same issue. spent weeks trying unsuccessfully update the click that came with my Hub One.

In the interim I just installed a spare cassette on the Zwift Hub and went old school.

Finally managed to talk Zwift into sending me another click, (that was initially another nightmare), and when it arrived was the same! “Setting DFU mode” moving bar, until the click loses interest and powers off, and the Zwift companion app locks up and has to be manually forced to stop.

Having run out of options I kept on trying over the weekend with the replacement click, just in case I was missing something, and then one day it just randomly worked!?? Maybe Zwift have updated their “updating” software?! I wish I knew!
Realize this may not be helpful, just wanted to share my experience.

I had the same problem. I only run the Companion app on my phone, not the Zwift app. I run Zwift on a laptop. However, after being unable to update the Click firmware because the Companion app was stuck on ‘Setting DFU mode’, I tried installing Zwift on my phone. Still nothing. I also noticed that the led on the Click unit briefly flashed red and green, not the yellow that it’s supposed to when updating. I then uninstalled Zwift from my phone and suddenly the Companion app connected first time and I was able to update the firmware to the latest version. To me, this looks like a problem with the Companion app rather than the Click unit, but who knows? This is all a bit random and unscientific, but it might help someone. Ride on!

Hello everyone. This is Juan, a Zwift colleague. I have been reading each posts carefully and gathered information from you about being stuck in device firmware update mode. According to our reports, there are not many users affected by this. However, we care about your Zwift experience. I noticed that this unexpected behavior is commonly related to Android devices. The best alternative here would be to use Zwift Companion on a different smartphone or tablet to update the firmware. If the issue persists, I encourage you to contact us at zwift.com/contact-us to go deeper into each case.

Here’s another Android update failure (Samsung A8, Play controllers)

Hi all, New to the Zwift world and had exactly the same issues as reported on this thread. This is an Android problem, installing the companion app on my iPhone the Click firmware update completes instantly. My issue is now click connects, but drops whilst on rides. My gears disappear after a few seconds of riding. I have only had Zwift for less than 48hrs, customer experience is not great! The drive train nut saga, and now Click. I might just buy warmer clothes and just ride outside :frowning:

I have the same problem. I’ve now tried companion on two devices (both android), and I notice that I get one stage further (beyond the dreaded DFU mode screen) to the ‘install’ screen during the update based on using a different device, but it then fails, with an error code E0:55:E8C1:65:49, error code: 132. I’ve deenergised click, and the same result. Since the firmware update on the zwift hub, the resistance and power meter dropout despite them being connected to my device - not sure if this is connected to the click, but a bit of a mess. Spent a couple of weeks trying to resolve and no change. @Juan_Lopez10 i have contacted support but no feedback as yet. Is this simply a failure for android users? More support should be provided on this

My Firmware for Zwift Click won’t update and gets stuck on ‘Setting DFU mode’. Has anyone else had this problem? Any suggestions for solutions?

Im having the same problem. Any updates on the solution?

Just to let you guys know. What resolved this for me is simply restarting my phone and trying to update again. Works now. And I’m using android btw.