Zwift Click Dead After Firmware Update

Received my Zwift cog and click today. Installed the cog on my trainer with no problem. Opened the companion app and choose the hardware option. I pressed the click button. The app found it and instructed to update firmware. Update ended successfully. Now the click will not turn on. This sucks.

While waiting for support I took the back off the click and disconnected the battery. When I put it back together it started working. The app can find it but so far the game running on my laptop hasn’t found it.

Once the Zwift Companion (ZC) app has connected to the Click, please keep in mind it remains connected until you back out of the Zwift Hardware menu in ZC. While the Click is connected, it does not “advertise” itself to the game, so will be hidden from view.

I suggest backing out of the Zwift Hardware menu in ZC, and then try game connection again. If that still doesn’t work, I suggest force-closing ZC (and if that still doesn’t work – turning ZC device off and on.) Once the Click is no longer connected to the ZC device, the game should be able to detect and use it.

1 Like

Thanks for the tip. I made another attempt at connecting the click to the game on my laptop later in the evening. I left my phone downstairs just to be sure it wouldn’t connect. I was able to successfully pair the click in the game. However, the connection dropped right after I had paired it. I exited and restarted the game. After pressing a button to wake up the click it connected to the game successfully.