Zwift Bluetooth Connection with TACX Neo 2T

I have read a number of comments and potential solutions to Bluetooth connectivity problems between Zwift (on PC) and various trainers. After weeks of reading and much frustration without being able to solve the problem, I stumbled upon the solution, which in my case was a simple fix. I had been using my wife’s one year-old Lenovo IdeaPad PC (4GB Ram, Windows 10 OS, Bluetooth 4.0), which runs Zwift perfectly and connects immediately to the Tacx by switching on the Bluetooth. I then changed my ancient 2013 Asus Laptop (Windows 7), which also ran Zwift perfectly, and upgraded to an HP Pavilion (8GB, Windows 10, Bluetooth 4.2), so thought I was in for a very much improved Zwift experience, wrong! No matter what ‘fixes’ I tried, the PC would not run Zwift with the Tacx. I disconnected all Bluetooth devices, set the PC and the mobile to the same 2.4Ghz Wi-Fi frequency and also tried unsuccessfully to bridge between the trainer and the PC, but the Bluetooth signal would drop and I’d be left looking at a Zwift screen, immobile at zero Watts! Yesterday I checked my Anti-Virus (AVG in my case, which replaces Windows Defender). I thought I had amended settings to ‘allow’ the Zwift app, which I had but decided to add others such as graphics and screen drivers (sorry, my first post here and forum apparently doesn’t allow my ‘media’ screenshot) I then opened Zwift on the PC, turned on Bluetooth (previously un-paired any other Bluetooth devices), which immediately found the Tacx (NB: do not ‘pair’ the Tacx), and hey presto! The Zwift connection symbol of doom actually activated, the Tacx’ Bluetooth light came on (which it hadn’t previously) and after 3-weeks of trying, Zwift finally connected and found the Tacx signal. Seems that the firewall was preventing the Bluetooth connection, but after specifically making firewall exceptions, all now works fine. Hope this solution may help others.


Thanks for sharing.

That is one reason why I recommend ANT+ on a Windows PC.