Zwift atrocious frame rate

I have been out of zwift since March due to a house move. I reconnected yesterday and after a zwft software update (on windows) I tried to train but the frame rate was so slow you could visually count the frames. Same laptop as before (lenovo x1 extreme Core i7-8750H CPU @ 2.20GHz - 32GB
NVIDIA GeForce GTX 1050 Ti with Max-Q Design). 1Gb Fibre optic connection to my service provider. Laptop on a 1Gb LAN with the SP fiber gateway. Transfer rate and latency are within parameters when tested.

Lowering resolution to 720P produced no improvement. On zwiftalayzer I get a P1 of 2 and an average of 12fps.

Before (march):


I have rebooted the laptop, no improvement. The only changes are an elite rizer and new phone for the companion app. Switched both off, no improvement.

In the windows task list, you can see that zwift is driving the CPU at about 30-40% and heavily loading one GPU. No much else going on the laptop.

I am at a loss. Hopefully this is fixable, otherwise, I’ll need to find a different platform. It is just not playable as it is.

Comments and suggestions sought.


Far smarter people on this subject will likely jump in and help you (@Dave_ZPCMR are you about?) but couldn’t help but notice that your memory went from 64 to 32gb - could that be related in some way?

2nd screen grab shows you lasted 27mins! Ouch.

I was just about to light the Bat Signal and call @Dave_ZPCMR but @Dean beat me to it. It’s only 1:39AM in the UK… I’m sure Dave will be right here. :stuck_out_tongue:

Have you seen this article: Zwift on PC: The Ultimate Guide to Running Zwift at Its Very Best | Zwift Insider

I’m specifically thinking you may have an Nvidia driver setting issue - adaptive sync or triple buffering? SOMETHING changed recently IIRC that required Nvidia users to tweak a setting or take a performance hit.

While we’re at it: what version of Windows are you running?

Thanks for the comments. The 64GB to 32GB was due to a motherboard rplacement that broke support for 64GB. Still need to figure this out with Lenovo. Everything else runs fine, so I just assumed it has nothing to do with the reduction in RAM.

I just noticed something weird, though. If I run two screens, with zwift runnning fullscreen on one, everytime I click on a window on the 2nd screen, zwift minimizes (this is strange, but I think it has always been like that). If the windows task list is active, I can see that when this happens Zwift takes the GPU1 to around 60% and GPU 0 is sort of idle.
As soon as I bring zwift back to the foreground, Zwift lowers GPU1 utilization to about 20% and two additional tasks pop up: “Desktop window management” and “Service Host: Game DVR and broadcast user service” both running high loads on GPU0.

It does sound like something windows broke. I’m running:

Edition Windows 10 Pro
Version 21H1
Installed on ‎31/‎03/‎2021
OS build 19043.1586
Experience Windows Feature Experience Pack 120.2212.4170.0

Ok, found it :). Googling “Service Host: Game DVR and broadcast user service” found entries of people complaing about lowered frame rates. Going to Settings > Gaming > Captures and turning off background recording (“Record in the background while I’m playing a game”) fixed it. Why it was on, no idea.

Report abuse


Yeah you don’t want to be screen recording, not unless you set it up accordingly anyway. I suspect it was encoding using your CPU (rather than the dedicated encoder on the GPU) and this was tanking the performance. The telltale sign is this:

That’s because the game was CPU bound at that point.

It has always been like that, use Zwift in Windowed mode and then use the borderlessgaming app to make it look full screen.

Any ideas how to sort this on windows 11? Can’t find the option in settings/gaming…

You can change to windowed mode in the Zwift app.

You need to install borderlessgaming if you want to simulate full screen.

Not too pushed about full screen or windowed, i’ll change out of full screen and see how it goes!