zwift app dies on startup on my Apple 4k TV


(Lee Duncan) #1

I started using Zwift last winter, and I’ve used it up until about 2 months ago. I tried to use it yesterday and today after this time off, and the Zwift app will not even run on my Apple 4k TV!

This worked last time I tried it, so I’m pretty sure I haven’t screwed anything up. I do not have any bluetooth devices in the room for the Apple TV to even pair with.

Do I have to just give up on Zwift?


(Steve Ellis) #2

Lee: be sure that your AppleTV Zwift app has been updated to the latest version. There have been updates since you last used it 2 months ago.


(Lee Duncan) #3

Steve, that was the first thing I checked. Evidently no updates. I cannot tell you which version I have, since the App tries to start but doesn’t get far enough for any display except a Z. But checking for any App updates yields an “You are all up to date” message. I also tried rebooting my Apple TV, and rebooting my TV, as well as making sure I was not logged into Zwift via any other App or Web page.

I’m baffled. It just looks like a bug in the App, to me, but since I can’t see any messages I have no idea what it’s not liking.

I thought about deleting then re-installing the App, but that just seemed desperate. :slight_smile:


(Isaac Escobar (Zwift HQ)) #4

Hey! Just a few questions:

When’s the last time you updated the app manually? There have been many updates and new features released in the past few weeks. It’s possible your using an outdated version of Zwift.

You also mention that the zwift app dies on start up, but what happens exactly? Does the app get put into the back ground? Or does the app completely close and you have to relaunch the app every time? If the app gets backgrounded, can you just select it and open the game?

Prior to the app dying on startup, when’s the last time you rode on zwift?

Do you normally use the Zwift Companion App while pairing devices? Or do you just use apple tv’s native bluetooth?


(Steve Ellis) #5

Lee:

The next thing I’d look into: force close the app (described here by iMore) then restart it .

How to force-close an app with the Siri Remote on Apple TV

If an app is acting up on Apple TV, you can use Multitasking to force-close it. You can open Multitasking from any app or screen, but for simplicity’s sake, we will start from the Home screen.

  1. Turn on  Apple TV.

While on the Home screen, double-click the  TV button  on the Siri Remote. It is the top button on the right side of the face of the remote with a TV icon on it.

The Home button on the Siri Remote

  1. Swipe to the right on the  trackpad  to find the app you wish to force-close.

Swipe up on the  trackpad  to force the app to close.

Swipe right on the trackpad to find the app, then swipe up to force-close it

To exit Multitasking, press the  Menu button  on the Siri Remote, which is the top button on the left side of the face of the remote. It has the word “Menu” on it.


(Steve Ellis) #6

If force-closing and restarting doesn’t help, I’d delete the app and reinstall it as you suggested. 

The app pretty much ought to just start and work. It’s the same hardware and same OS used by many other Zwifters. So I wouldn’t give up.


(Steve Ellis) #7

Version number, currently: you should see 1.0.28834 in the bottom right corner of the app start up screen.


(Lee Duncan) #8

Thank you Steve and Issac for your help. I ended up deleting then reinstalling the App. First try, it failed to start up, showing only a blank white-ish screen before falling back to the main home screen. But I tried again, and it actually worked! Repeated exit/entry convinces me it is working now, again.

Totally not sure why it didn’t like something. My last ride was actually in April (longer ago than I thought), and I have auto-App-update turned on, so maybe something new in the App didn’t like my old Data? Just a SWAG. :slight_smile:

Thanks again for your help.


(Isaac Escobar (Zwift HQ)) #9

Glad everything turned out okay and you didnt have to leave Zwift :]

Ride On!