Zwift doesn’t work with AppleTVOS 12.1

When launching the Zwift app on Apple TV 4K running TVOS 12.1 the launch screen (blue with Zwift logo) just hangs for a few minutes then the app quits. I’ve tried the following:

  1. Deleting and reinstalling Zwift app
  2. Hard restart of AppleTV (power off)

Nothing has helped. It appears the latest Zwift update is not compatible with Apple TV OS 12.1.

I read your post JUST as my AppleTV was updating, and I thought “Oh no”. I got the same thing, once it updated I got the blue screen hanging then quits. When I deleted and re-installed though, I did something that may help. Once it installed, I opened the app from the App store instead of from the home screen. It opened, I put in my credentials, and worked. I then opened it from the home screen, and it worked.

I’m running 12.1 on an Apple TV 4K. The first time I launched Zwift it crashed, but it has been fine ever since. Try rebooting your smart trainers.

Similar experience for me on ATV4K. Blue screen hangs then kicks me back to the desktop, or sometimes just hangs on a white screen never getting to the blue splash screen before kicking back to the desktop. I have reinstalled Zwift a couple times but still have the same experience. I have found that trying to start it 3 or 4 times over eventually it will load.

I’m having the exact same issues as well. Only way to get it to work for me is to keep trying to open it and eventually it’ll start, sometimes it’s only 2-3 tries but other times, like right now, after 10 tries it still won’t open.

Investigating! Will update as soon as possible.

In the meantime if you find any workaround that consistently works feel free to post it here, it’ll help aide the investigation.

Edit: A question from our Quality Assurance team: Can you all time how long it takes for your Zwift app to boot you back to the home screen if it does?

For me it’s usually about 15 seconds.

Any updates since November? I’m finally getting things going again for this winter. The setup worked perfectly all last winter. Nothing changed other than the date. But now when I try to boot up Zwift on AppleTV 4K, it goes to the blue screen with the Z logo and that’s it. The music plays, but nothing else happens - and it doesn’t quit either. At first I thought that maybe it was sitting in a long app update phase, but it seems that it’s been updating all along regardless of my usage.

Hey Charlie, are you still getting the blue screen stall even after restarting your Apple TV? Or have you tried uninstalling the app then reinstalling it?

If he isn’t, I am. I started Zwift today via my Apple TV (non-4k, presumably updated to 12.01) and I just hear the background music and see a white Z with a blue background. I’m subscribed and basically can’t use the app right now. :frowning:

Here’s a screenshot of the issue.

EDIT: I went in and manually updated my Apple TV in the software center, and it seems to have fixed the issue.