Zwift app crash after race end [1.39] [May 2023] [SOLVED]

since update 1.39.0 the app crashed on both races I’ve done while the results are displayed. I’m on a Wahoo Kickr bike v2 connected via LAN to windows 10. zwift power shows the results correctly although the 15 sec column never changes and the timeline on zwift is missing the last 4 minutes of 24 minute race. I’ve also noticed the new steering dropdown doesn’t show any devices to toggle on or off yet at the beginning I get the message it won’t be active during the race. My theory is that at the end of the race the app tries to re-activate steering and update the dropdown status which is empty and crashes. Would love it if you could go back to previous release. That worked fine even for steering which I always turn off anyway. Now you can’t. Nothing appears in the dropdown no matter how long you wait.

1 Like

Same here, but not on bike (no steering). Kickr v5 connected via LAN to Win10. Zwift crashed yesterday after the end of the race while I was looking at the results.

1 Like

+1. Last two races I’ve done it’s crashed while scrolling through the results page. Running on windows. Not an issue with steering as I don’t have any (Wattbike Atom V2) connected via the Companion App.

1 Like

I had a game crash while scrolling the results page after a race two days ago as well. On macOS Ventura, Zwift 1.39. No steering equipment.

1 Like

Same game crash here while scrolling through results. On wahoo kickr core connected with ant+ to macOS Monterey with Zwift 1.39. No steering equipment

1 Like

I updated my nvidia graphics as Zwift suggested and will do a race later today. there doesn’t appear to be based on responses a connection to steering but it was the most conspicuous change and definitely a bug in terms of the dropdown not showing it. I’ve had 2 races and 2 crashes so we’ll see.

@shooj , @xflintx just had my 1st Zwift Crash in 4years it was after a Race…i finished a race and hit Stay Here to continue my ride for a few more kilometers and hit END RIDE…and in the menu before saving i wanted to check RACE RESULTS and when i changed from my B Category to C the Zwift crashed.

This is the activity The at Home Cycling & Running Virtual Training App
I could download the FIT File from to upload to Garmin/Strava/Intervals if anyone will have this problem just go to The at Home Cycling & Running Virtual Training App any click Just Me in Activity filters and download the FIT File from here…the one on your computer is corrupted.


You are not alone

1 Like

Hi @Rodja_Dodja @Aleksei_Nesterov @David_Galbraith @Paul_Southworth @Marjolein_de_Vlieghe @DejanPresen

We made a server-side change two days ago that may (or may not) be related to your symptoms. That change has been undone, and we’d like you to try another race on Zwift to see if the crash happens in a similar situation.

VERY IMPORTANT: Please reboot your computer / mobile device before the next attempt. Powering off and restarting is especially important with tablets / AppleTV / smartphones.


Will do. I rode a race this afternoon and didn’t crash but I neglected to scroll the results. I simply finished and exited via the menu. No problem. I thought after the first crash I was just sitting recovering and it crashed. Can’t be sure. I’ll reboot and do another race in the next day or so, filter on my category and scroll around. Yesterday I applied nvidia firmware so I’m up to date. Not sure if that matters since some of the crashes were Apple machines. Thanks Shuji.

Just now crash while scrolling through results. BTW my result was again in the wrong category. Maybe it’s somehow related

Quick update, the fix for this will be coming up on the next game release :raised_hands:

1 Like

I finished 2 races today without crashing. The first didn’t have enough entries to scroll but I clicked through the different cat results and exited no problem. The second had multiple pages worth of entries and I scrolled up and down the different categories again no problem.

Question, Adrian what were you referring to in “fix for this”, the wrong category, crashing, or both?

Referring to the crashing

1 Like

Hi everyone, this issue is solved with game release v 1.40 which began phased rollout today. Over the following two days, it should be available to everyone. Please update at your earliest convenience.


UPDATE May 19:
Rollout of v1.40 to all devices on all OS platforms is complete. Please update at your earliest convenience.

If you continue to have issues - first confirm you’re using v1.40, and if needed - contact Zwift Community Support. I will mark this thread solved and set to close it in two weeks’ time.

This topic was automatically closed after 9 days. New replies are no longer allowed.