Zwift ant+ litteraly stops working for unknown reason. Won't see my trainer

I have the zwift cycleops m2 package so everything is compatible and has been working perfectly since November. Today, all of a sudden, initially everything works for like 20 seconds and then there’s some in-game glitch in the screen and I lose all reception from my trainer. No more anything. All of a sudden . I tried restarting the game, the ant+ got unplugged and plugged, same with the trainer. I tried updating my ant+ drivers, tried stopping and restarting my USB bus right in my PC. But nothing. Tried it anyway even though everything else was still working fine. I then tried Rouvy demo. And oh, everything works…
So I uninstalled and reinstalled zwift.

Still nothing. Help me please this is seriously annoying me, I wasted a solid hour trying to fix it by myself with no success…

Hey Alexandre this issue would best be handled by our support team.

Please submit a support ticket by following the link provided and please include as many log files as possible when you do.

We are happy to dig into this issue with you!