Zwift Android App

I cant get my Zwift Android Mobile App to display anything other than names of riders…I see some of the app reviews say the same thing. Any ideas about what I might be doing wrong???

i had the same issue happen a couple of times. i had to reboot my Android phone twice. had to leave it off for awhile the second time. After that when it failed, I just logged off of the Zwift app and back on. I saw that an update of the Android app installed on my phone last night, so maybe an update. I had no problems this morning.

Gerald…thanks for the advice, but I’m still a no-go on the app…even Uninstaller and reinstalled it. Frustrating…

Same here. I tried 3 different devices with the same result. I only see a list of riders. No dashboard. Not sure what the problem is. :frowning:

Same problem - both computer and phone are on the same wifi connection but no dashboard on the phone, just the rider list.

I’m having the same issue. My fiancee has the same phone and is able to use the app just fine, but I’m a no-go. I even went so far as to uninstall it and clear the cache partition on my phone. :confused:

I still have intermittent problems with mine. The issue hasnt gone away, but I seem to have found a consistent solution in fixing it. When the problem occurs the first thing I try is to logout of the zwift mobile link app and then log back in. Failing that, I again, log out of the Zwift mobile link app, then turn the phone off for at least a minute, then turn back on. One thing I found that helped was I have ¨fast boot¨ turned off on my phone. Under Settings | Power | Fast boot. I am not sure if all Android phones have this feature, but turning it off seems to allow a reboot to fix some application issues.

Is your phone on the same WiFi network as the computer you’re riding Zwift is?

In my case - yes - same wifi network.

Eric at Zwift…nope. I have a dual band router…they are on different bands.

Same WiFi network in my case as well.

Same Wifi for me as well. Tried two different brand of access point as well. I disabled anti-virus and firewall as well just for the sake of being sure. I have 4 Android devices with various OS versions as well (S2, S3, Nexus 4, Tab 4). They all exhibit the same behavior. So I would say it’s definitely tied to the network. Is there anything on the router/AP that we should enable/disable that you could think of Eric?

My android app on the Samsung Galaxy S4 is now working. I think it was user error. I didn’t realize you needed to be on wifi for it to work. All is good!

I’ve tried it on two separate WiFi networks (mine and my fiancee’s). His works fine at his house, mine doesn’t work in either place, whether using my computer or his.

For kicks, I wiped my phone and started with a totally clean slate. Still no luck.

I will also note that when I first got the app working and not crashing, all it showed was a list of who was riding. It wasn’t until I actual joined the game that all other functionality appeared.

Release 17 (March 12) fixed all issues for me. As an FYI, the computer is wired to the network and the Android device connects through Wifi.

I signed up via my MAC, but I use a Samsung Galaxy S5. I am not recognized when I sign in, but I have no problem signing in on the MACs.  Any one else with this issue?

Same problem.

Fixed itself when I logged in to the game on my pc, then rebooted my phone. 

A reboot of the phone worked for me.  Thanks 

My android  Samsung note 5 is on the same wifi network as the computer. 

I am not seeing the dashboard screen and the game controller screen , only seeing the list of rider, my  profile and feed.