Zwift acceleration bug

This morning I seem to be suffering with this bug (anyone else?), I found myself doing up to 100kph for normal effort levels - I could do 50kph on the flat @100 watts and no draft. I had to quit several events which was very frustrating.

I’m running Zwift on a PC - Win10, I’ve removed and re-installed, tried two different pwr sources (Kickr5 & Garmin S3’s), my numbers are right in terms of watts - but the speed is crazy.

Ticket logged with Support

I don’t believe reinstalling Zwift should ever be an option. Any existing bug will not be resolved by re-installing, and if Zwift “develops” an issue while working - it is a bug, just like any bug, that needs to be fixed.

The mere acceptance by Zwift community of this (common) practice is beyond me… Software is not witchcraft.

1 Like

You’re not wrong, but what about version patching that may not complete correctly without the user knowing? In that instance a clean install of the latest full game could be beneficial.


the re-install was an act of desperation tbh.

Just tried again - bug is still there

1 Like

Doesn’t that qualify as “bug”?

We’ve (Zwifters) all become accustomed to dealing with Zwift “issues” in like manner, whereas in reality these are all Zwift bugs.

I challenge anyone to name any other non-negligable S/W that needs such…

1 Like

Not disagreeing with you at all. Just saying there are almost certainly instances where it could help, if only due to the billions of combinations of PC hardware out there. It could be a network error as well, that’s not necessarily a bug, unless you get into how the patch installer deals with such a thing…

UPDATE - I’ve fixed the issue. my height had changed to 18cm, no idea how this happened.

1 Like

So what you are saying is that if I want to win races, all I need to do is reduce my height?

Height doping is a known thing in Zwift unfortunately