Zwift Academy baseline ride no segments

Just finished this ride and I didn’t get any sprint segments. It also never switched my bike to a tt bike.


I had the same issue two days ago! I’ve wrote an email, without getting a convincing reply though.

How did you both join the workout? Which platform are you on?

@Joy_Ross I’ve had a look at the screenshots for your activity, they look a bit odd and not like you did the Vaseline ride (but obviously you did).

Hi @James_Zwift ,

I had the same issue yesterday. I joined the event (Ipad app) but never entered workout mode. I had no bike switching, no finish line / workout summary, and no instructions on screen. The companion app says “Group Ride”, therefore it shows up in zwiftpower as an activity but am not listed in the results.
(I did continue riding after the screenshot, total activity was 29.5km long)

Thanks - On my Zwift display, the UI wasn’t a workout, but it was in the Companion App, but I got all the workout text prompts.

I’ll flag this thread with the team.

For me the companion app was also not in workout mode. Btw, not sure if relevant, but this was my second attempt after a first attempt that I didn’t completely finish.

I did the ride on iOS 15.4.1, not sure exactly which Zwift app version, but not the newest.
I was clearly riding the workout, as I saw the distance to complete, rankings, etc. just no on screen messages and segments.

I am using the Apple TV, and the baseline ride was categorized as an event not a workout. So I started a ride in Watopia. Then the prompt to join event came up and i selected Join Event.

Same issue here too. I attempted academy ride #1 twice today and it failed both times. No workout in companion app. No on screen instructions. I’ve raised a support case but no answers yet. On Apple TV - latest Zwift and latest TVos

Hi, I think I had the same issue, no on screen instructions (although I’ll be honest I wasn’t looking out for what bike I was on). I went a little way past the kom and have a (blank) email, but no progress in my companion app. Still at 0%. I joined through the link in a free ride , I’m not sure if that screwed up the instructions? I don’t know whether I need to redo the baseline ride to get credit, or if it’s pending?

When I did the baseline ride I was getting the on-screen instructions up until the first segment, then nothing after that. Confirmed with others around me that they could see instructions. I wasn’t looking at companion app workout screen, so possible the instructions were still coming up there - just not on my computer screen (on Windows 11 and latest game version).
Fortunately I know the course well, so lack of instructions wasn’t an issue.

Did yours register as part of Zwift Academy in the app afterwards Lucy?

I re-did my baseline Jimmy - it worked the second time. However the next Academy race didn’t work for me yesterday - same problem.

Hi Steve - yes, everything registered fine. It was just missing the on-screen prompts.

Im still waiting for an email 3 days after completing the baseline. Assuming all my settings for getting emails are correct. Zwift and Companion App both show it as completed so thats not the issue and believe i did it afterinitial bugs sorted.

1 Like

So Zwift got in touch and credited me with the baseline ride, I don’t have the data for it yet though. It sounds like they have a few issues with that! I did my first workout today and it all worked ok for me.