Zwift 1.33.4 lost trainer connection

Hi, I have just updated Zwift to 1.33.4 and now my Elite Suito doesn’t change resistance either in freeride or workouts. It worked fine last week with Zwift (before the update) and still works perfectly with the Elite training app. I’ve checked my ant+ drivers and uninstalled/reinstalled Zwift but with no joy. My smart trainer is effectively a very expensive dumb trainer atm. Is anyone else seeing anything similar?

Same thing with Tacx Neo.
Worked perfect in 1.33.3 but no signal in 1.33.4 on Apple TV. Works on iOS 1.33.4 though, so the bug seems to be limited to the Apple TV version.
Same bike works fine on FulGaz on Apple TV, so definite an issue with the Zwift app 1.33.4 on Apple TV.

This has come up recently. Zwift on ATV went bonkers on me after an update a month or two ago.

Do a factory reset of the AppleTV, followed by updating the TVOS, restarting, and reinstalling Zwift. (it should do so automatically if you restore your ATV from iCloud)

Ensure the NEO isn’t paired with any other devices. (watches, bike computers, PC’s, tablets, phones, apps) Also ensure the Zwift Companion app is uninstalled from any device you had it on. You can reinstall it post ATV reset. (that last one might be overkill but it’s one more box to check)

I was on Windows 10 rather than ATV - finally got things going again for now by uninstalling and reinstalling everything I could think of related to Zwift/ANT+/Bluetooth - software, dongles, drivers etc. Utterly unscientific approach so I don’t know what specific individual thing was causing the problem, but it’s working again now.

1 Like