ZC picking up trainer but not power

Hi

Just starting with zwift, have done a ride with just the app and now moving on to the companion.

I can get cadence and controllable trainer to connect but not power.

These all connect on the zwift app.

I’ve tried closing all other apps and restarting the trainer. I’m running an elite novo smart.

Obviously connection to zc is working as I can see the cadence and control.

Any ideas?

Thanks!

Hi @D_E1, welcome to the forums. What devices are you using for Zwift and what trainer or sensors do you use on your bike? If you can already connect to your device that runs the main Zwift app then why do you need to connect them via the companion app?

2 Likes

Are you running a power meter on your bike independent of the trainer?

Hi both, thanks.
Sorry should have been clearer: the power meter is the one in the trainer, no other sensors on the bike.

I want to use the companion app so that I can use zwift on the computer with companion app as the second screen

How is your trainer connected to Zwift, BlueTooth or ANT+? I also use the companion app while riding but I turn off the Bluetooth in the Companion App just to avoid conflicts. I connect my trainer directly to my IPad or PC. The Companion app picks everything up through the same WIFI connection and allows me complete functionality.

You say that you get “cadence and a controllable trainer” to connect. You mean directly to the Zwift app? Not through the companion app, right? That implies that cadence is an independent sensor from your trainer but you say that the trainer is the only connection to Zwift.

What platform are you running Zwift on and how is cadence connected and how is the controllable trainer connected?

Hi,

When I connect on zwift on my phone (android) I have to select the trainer in all three options (power, cadence and controllable trainer).

When I attempt this from my pc, for whatever reason, it doesn’t see the trainer at all. When I use the companion app to help the PC it can see the trainer for cadence and controllable but not power

All bluetooth

Thanks!

OK, a couple things. When you connect to a controllable trainer you only need to select the option that says POWER SOURCE. The trainer will provide cadence, speed and power. You don’t need to separately connect cadence or power. NOW my PC running windows 10 is kinda old, and it doesn’t have Bluetooth so I need to connect to ANT+ using a dongle but I still only have to select Power Source. When I use my IPad, which has built in Bluetooth, I only need to select power source and my trainer sends over Cadence and Power . I never have to connect separately to my cadence nor speed sensor.
Now, when you use the Companion app as a bridge you need to be careful about other Bluetooth devices. It could be something else is grabbing that power signal so make sure nothing else that has Bluetooth is connected, like your Garmin computer or Wahoo computer for example.

Thanks for this, was going to try today but my internet is down! Will have to be tomorrow, hopefully

Hey, sorry been a few days.

Right tried this over the weekend but no joy.

The website is recognised as a cadence sensor but not as a power sensor by the companion app (it’s all the same sensor), without power I can’t use zwift (just to restate the app can recognise it as a power source)

Anyone seen this before?

Sorry not website, trainer

I don’t think you ever told what trainer you are using?

It’s an elite novo smart