Workouts not registering as complete in training plan

Anyone know why my workouts are not marking as complete on my training plan? Despite them being there is zwift companion?

Really frustrating because it’s messing with my plans and actually showing full completion. Find this super annoying hoping I’m not the only one who has experienced this before?

Help would be fabulous!

Hi @Stephanie_Giles

Shuji at Zwift HQ here. I looked at your session logs, and I see you’re using an iPad4. Further, there are instances when you log in but don’t exit the app. It’s the type of scenario where you might be checking what badges you’ve done, or possibly - to check on your workout plan.

Swiping the app away just puts it in the background, but it’s still running. Whenever you log in - please either 1) save & upload or 2) trashcan the session. This is the only sure way to log out.

Please do this moving forward, and your workouts will save correctly, and you should see them correctly on your game app.

1 Like

I have experienced the same on my last 2 workouts. Using iPad - can you please explain the steps as I think I am doing the same as previous workouts, so not sure why this is happening.

See Previously completed workout in training plan showing incomplete next session [SOLVED]

Thanks Steve - I’m not the only one then!!

I have marked as complete manually.

Same here - I was good through last Thursday then the last session of the week I completed on Saturday but it did not register as being completed. I completed the session that became available on Monday of this week yesterday and today and it does not show complete. When I go to the Training Plan as soon as I complete the session there is a white rectangle where the workout had been but still shows the prior and subsequent workouts. On the companion the Training Plan no longer shows the workout just completed
in the overall plan.

I am also having the exact same issue. I am onto week 3 of a plan and everything was fine until my Saturday ride. It did not register and I had to mark as ‘completed outside’. Onto week 3 this morning, the activity again has not marked as complete and in the app, the workout is just blanked out with a white background. A wider issue with Zwift maybe?

@here @zwift @shooj
Both my girlfriend and I are newly experiencing this issue following the latest update. We are using IPad Air 4 with Companion App on IPhone. We are saving properly with updates being pushed to Garmin and Strava. This is NOT user error. Please your fix your bug

1 Like

similar issue, and zwift shows the completed activity, but the program doesn’t and I had to manually enter that i completed it… happened this past week with Apple TV.

On a side note, what exactly happens when you “complete” a training program? extra bonus points? a badge somewhere?

My last 3 workouts haven’t registered either. Getting tired of doing them twice and not having them register.

2 Likes

Hello all,

The same for me.

My two lasts WO in Gran Fondo training plan haven’t been recorded as done in the training plan.

I trained yesterday and today, by doing those two WO. Sessions are well exported to Garmin Connect, but don’t appear as done in the Gran Fondo training plan.

Thank you for debugging :wink:.

Same issue on my end. Doing the “Build Me Up” training plan. I complete the workout on my trainer using Swift on my iPhone 12 Pro Max. I finish, end my ride, upload to Strava. But Zwift is not marking it as complete and I have to manually mark it as complete.

Same issue here for both me and my girlfriend. Although the training is uploaded to Strava correctly, it is not recorded in Zwift. On that note, I noticed that the title of the workout in Strava is different from what it used to be; a week ago, the training plan was mentioned, followed by the name of the training session, but now only the latter is mentioned…

Seems to be an issue with the latest Zwift update, not a user problem…

Same here. Using Zwift on iPad + Companion on iPhone. Training plan is Build me up. Workouts correctly ended via app, uploaded to Companion and Strava, but still showing as not completed on the training plan.

Same for me. I‘m Using iPhone 11 with IOS 14.4 and the Last 3 Trainings weren‘t Registered in the Trainings plan

I’m having a similar issue. Last three workouts from ftp builder plan are recorded in ‘Activities’ on Companion but nowhere else i.e. they don’t appear on Zwift app OR in Companion under ‘Training Plan’. Workouts still appear as ‘due’ in Zwift app and Companion. Seems to be happening since Zwift update five days ago. This is incredibly frustrating. User error or WiFi signal are not issues as I have ended all rides correctly, as before, and I have a strong WiFi signal. Any information would be greatly appreciated.

Btw I’m using Apple TV.

As frustrating as this is, I did not find anything to resolve the issue other than having to do the ride again in order for it to register and complete the training plan. Albeit inside the time you have to do the ride in!
Once the ride has greyed out you can still do it outside of the training plan but it does not register as complete. This is ok if you don’t get below the 80% completion rate on the plan meaning you don’t hit it!
I have tried numerous things to understand functionality wise what is going on…outside of charging batteries full, changing devices and crossing my fingers it won’t repeat nothing seems to work. Feels like it sometimes happens and it sometimes doesn’t. Clearly a wider issue given the thread.

Same issue here - I’m doing Back to Fitness. I did “Strength Endurance + REV for :15 seconds” on Monday and when I went to ride today it tried to start me in the workout again. I declined but after I finished my ride I went to the companion app. It shows me completing the workout on Monday under Activities, but if I go to Training Plan, it says I need to complete it by tonight. My training plan also shows that I didn’t complete the previous one (“Over Under’s 4 x 4 min”), which Activities shows me completing on Feb 27. Both rides are also on Strava. Is there a way to bring my training plan up-to-date with reality? Thanks - Jim

p.s. I use an iPad Pro 12.9 for Zwift and an iPhone for the companion app.

Same issue here, really frustrating, they are showing in the app as an activity but not in the plan