Workout not counting for Plan

Hi, updated my system today and performed a workout in “Back to fitness” - Strength Builder.
The activity is recorded correctly in Zwift, however the training plan is show this activity as still needing to be completed “Due in 9hours14mins”. How can this be rectified? How can I even speak to Zwift about it? :smiley:

I have the exact same problem. Two days in a row now. Both after the latest update on iOS. Up until the update it has work flawlessly.

Yep. Precisely the same issue here as well. My last two workouts in the “Build Me Up” training plan haven’t appeared as completed, despite them being recorded and shown in my activity feed.

This started after the most recent Zwift update on iPadOS just a couple of days ago. Prior to that, I had no issues.

As a workaround, I’ve had to manually mark the activities as complete and now they’re shown as having been completed “Outside”. Oddly, the screen to do that has been a big buggy, and I’ve had to force-close the app in order for the missing workout to appear so that I can then mark it as complete.

Something’s definitely broken.

I reported this via email yesterday and had an email from Tech Support to say they’re looking at it.

Mine shows as a completed activity with the “Finished Workout” achievement, the ride sync’d to Strava (so no issues with my network connection) - but this hasn’t been reflected as completed in the Training Plan. Whenever I fire up the game I’m still prompted to go do the workout that I’ve already done

Running ZWIFT on an Apple TV running the new update of ZWIFT released in the last few days

Post your details here if you’re seeing similar.

Same issue for me. I’m on week 5 of “Build Me Up” and completed “Tine” 2 days ago. Registered that I completed the workout in zwift and strava but the training plan does not show that I completed the training (no check next to it).

Also a workout I just completed went missing. I completed “Escalation” and registered as completed under Activities but now it’s no longer listed under “Build Me Up”.

Running app on Apple TV with latest zwift updated (2 days ago) w/ companion app on iPad.

I should also add I’m using Apple TV, at least 3 of us are in the same boat here in terms of hardware.

Not that this is the only Apple TV bug! :slight_smile:

Same issue here on iPad. Good to know I’m not alone!

I met exact same problem since last Friday, I can see all of my workouts from activity feed, so I assume they are uploaded properly, but can’t count in workout plan, I’m working on “Build me up” too.
my setup is iPad mini, with latest app version. Also I’ve tried to delete the zwift app, clean up local data and re-install it, didn’t help.
I’ve sent a mail to support team yesterday, I think they are working on it

See Previously completed workout in training plan showing incomplete next session

Running into this on Apple TV as well. Since Friday Feb 26. It appears the app updated the day before to version 1.0.63186. I never had the issue before then.

This issue also appears to be the same referenced in issue 540722 from this forum (it seems I’m unable to actually embed the link to it in this post :frowning:)

Yeah. I’ve got a similar problem trying to do Build Me Up on an AppleTV setup.

It’s showing me as having not completed “Cadence Adjustment” - when I very clearly did. And it has shown “Uphill Battle” as “expired” - when I was planning on doing it today.

A bit frustrating, I must say. I’m sure there are workarounds, but the AppleTV Zwift app seems to have gotten a bit buggy recently.

I had the same problem… any resolution?

All: this bug has been fixed in game version 1.11.0 that released today.

Please update your game app, especially for those on iOS / Apple TV / Android