Training Plan (Build Me Up) not capturing workouts after completion?

Is anyone else having issues with Training Plan workouts not being checked off as ‘completed’ after…well… completing the workout?

All week long I’v been having this problem. I’ll do a workout as part of the Build Me Up training plan, go through the whole thing where it shows my effort at the end vs. prescribed intervals, shows up as completed in the Plan Progress screen etc. I save & exit. The workout syncs to my Strava account, and shows up in the companion app as an Activity… all normal.

But then, If I check my training plan progress in the Companion app to see what’s coming up, or if I sign back into Zwift on my laptop, the workout(s) I’ve JUST done still show up as ‘Due by _____ night’ or ‘Due in # hrs min sec’ with a countdown.

Then, my only option is to check ‘I did it’ before it expires when the timer runs out. That’s ok, except that the training plan then isn’t accurately capturing my totals for training time, distance, calories, etc in Zwift.

This happened to me once before the last time I did this plan (over the summer) - but it was just a one-off problem. Now, it’s happening with every workout!

Anyone?

I have the same problem with the Build me up plan. Does not save training progress

Hi @alessandro_massari welcome to the Zwift Forum.

We will need a bit more information, like what system you are using. Is this the first time this has happened?

Since last week, the training plan does not advance me. I had previously worked with ftp build and everything was correct. With build me up I finish the training, it updates me strava, but when zwift starts the next day it keeps letting me choose the type of training plan.
This morning I tried to uninstall and install zwift again on PC

I’m running Zwift on a Windows 10 laptop, connected via ANT+ to an Elite Direto.

For me, all of the issues happened during Build Me Up workouts in Week 2 (https://whatsonzwift.com/workouts/build-me-up/#week-2).

Since then, it’s been working fine. I completed Week 3 on Sunday. No issues. Can’t say if it’s something unique to the Week 2 workouts, or if the most recent Zwift update fixed whatever bug was causing the problem.

1 Like

good that things now works.

1 Like

Zwift still does not work. It does not store and does not update the training progresses. I have installed the program from scratch, deleted both Zwift Companion and the results saved on strava. Everything useless. Then I tried to force manually the procedure, but this one was unsuccessful as well. Do you have any other solutions to try?

Had this yesterday, but not sure if quite the same issue.

Completed the workout, saved as normal. Workout never made it to Strava and didn’t show in Zwift. Did a manual upload to Strava and TP, it was missing last 10 mins. Obviously now Zwift is showing the workout as not completed.

I raised a support ticket, response was that is was probably my connection and to try a big list of things to improve WiFi, connection, not run other apps etc. Not much I can change my end at all and is the first time it has ever happened in Zwift. I did have similar happen once in TR years ago but we think that was interference from a baby monitor.

It could in my view have been a Zwift side issue but nothing to go on.

1 Like

A very similar problem here: I completed a workout of my training plan, week 2. Everything looier fine: I had gained all stars, the overview looked neat, etc. But the workout was not showing up in my plan afterwards => the only “solution” was to complete that workout manually… :S

Two differences: I am following another plan (Pebble Pounder) and I am using iOS.

Having the same problem with the same plan (Build me up plan). Using Win10 + bluetooth connection with my Elite Suito trainer and after completing a workout, it’s just not synchronized into the plan. It’s uploaded to Strava and I can see it in Zwift Companion as an activity but not as completed workout. It’s very frustrating because I cannot see my progress in the plan and losing all the stars as well. Can you suggest me a solution? Thanks!

How do you end your workout and Zwift.

Once you are done click menu - end ride - save and exit.

I do exactly the same when I finish my session. I can see the summary (time - watts - distance - etc.). Uploading in progress. Strava shows the result. Zwift Companion also shows the activity. But the workout does not appear completed in the training plan.

and I assume you completed every step of the workout.

Same problem here, I finished Build Me Up Week 3 Novanta on Wednesday and it popped back up as needing to be done this morning. I had the completion screen and it showed up as done as the time, and it’s all transferred fine to Strava, just no longer showing up as done.

I realize this is an old post but, yeah, @Gerrie_Delport, it seems like this is a real bug. When it happened to me, I completed all stages of the workout and ‘save[d] & exit[ed]’ as always. It even displays the workout as ‘completed’ on the training plan progress screen before I quit/save/exit. And the activity shows up in the companion app AND on Strava. All completely as normal, EXCEPT that the workout still shows up in the companion app training plan as ‘Do by ______ night’ or ‘Due in HH:MM:SS’ depending on how close one was to the due date when the workout was completed. Also, the next time I launch Zwift (and precisely when that is) the same workout will either still be in my to-do list again, or it will be marked ‘unavailable’ if the due date has passed.

In the case of the former, one can just click ‘I did it’ to mark it complete. In the latter? There’s nothing to be done.

In the grand scheme? None if it really matters - because the work was still done even if the system doesn’t recognize it, and training is really all about the work, right? But enough people have had similar experiences that it’s probably something wrong with some part of the plan that could/should be fixed by Zwift. And it does seem to be unique to the Build Me Up plan. It’s happened to me both times I’ve completed this plan. By contrast, I just finished a 10 wk Gravel Grinder plan without a single hiccup.