Completion of training plan ride not recording as completed

Hi

It looks like other Zwifters are experiencing the same issue. For the last 5 weeks, I have been on the FTP training plan, and each time I finish a session, it gets ticked off as completed.

However, for the last three workouts, this has not happened; despite the ride appearing in my companion app feed as the correct workout and uploading to Strava, the session doesn’t get marked as completed.

Nothing has changed on my set up from the previous 5 weeks and 20+ workouts!

seeing same/similar - but a specific session on a training plan i’m following …

, is not registered against the training plan itself (Active Offseason - intermediate level), week 2 session 1 - ‘Cadence Into Over-Unders’ i’ve hit the ‘I DID IT’ ‘button’ bottom right to show it as done - but obviously no metrics - defaults to ‘RODE OUTSIDE’

1 Like

See Previously completed workout in training plan showing incomplete next session

2 Likes

I have the same issue. The click “I did workout” fixed the issue for the short term.

1 Like

I noticed when I look on Zwift power, the name of the program has changed and this is when the issues coincidently started with the completed workout ride not recording as completed in the workout schedule.

The rides with 6wk Beginner have not been recored those before were always marked complete.

“I did it” does work and thanks for informing me on how to do this).

Screenshot 2021-03-04 at 13.05.29

Thanks Steve, coincidently the issue started when the (without me doing anything) the title of the workout changed - see below from Saturday the workouts have not been marked (automatically) as completed.

Screenshot 2021-03-04 at 13.05.29

hi Steve, i presume no ‘metrics’ are shown against that ( that’s what’s happening when i do same to mine )

I’m seeing the same thing… they appear in my feed but no metrics are captured! All I can do is tick “completed/rode outside” :frowning:

I have a similar problem.

I just noticed that EIGHT workouts that I previously completed on the Build Me Up plan and now shown as “Expired” - when I completed them. I have the Strava records that I did.

This is completely unacceptable to me. Zwift needs to fix this. This isn’t a minor inconvenience or annoyance.

It’s a dealbreaker for me.

1 Like

Zwift say that this problem will be sorted in the next game update!

Any ideas how to get the workout metrics you’ve already done captured in the summary after the workout?
I’ve followed the manually “I did it” but no metrics like time are captured just number of workouts done… I’ve done the update so had hoped the rest would be added!