Workout interrupted -- at least 9 times!

For your iPad, you can get the log file and put it in Zwiftalizer

Also, I would recommend you force quit all other apps running on the iPad before you start your Zwift session.

Lastly, Apple released updates for iOS and iPad OS. Recommend you upgrade your OS as well.

1 Like

Thanks! Just did that for a sampling of the log files from yesterday. Nothing jumps out at me, but then I don’t know what to look for. They all look a lot like this one:

And a note that my ipad is using an older version of the game…but I don’t think they’ve released the ios update yet?

They have released it. Check the App Store.

1 Like

Just checked, and my iPad app is up-to-date. It could have updated after yesterday’s ride, though.

I’ve got another workout on the training calendar for tomorrow. I’ll implement all the suggestions here and give it a whirl

Thanks!

EDIT: also updated iOS for good measure

It’s happening all the time due to the mass of people using at once it’s been 2 weeks since zwift last work as you would like waste of time

Hi @MaryBeth_Vellequette

Shuji at Zwift HQ here. I see your multiple logins recorded on our sever on January 26. All of those logins were on an older (problematic) game version running on iPad.

The final login was from a Windows machine running the latest version 1.0.61590. Did this error also happen on the Windows machine?

I’m curious what happened after you updated iOS + run the latest iOS version of Zwift. Apple released a critical iOS security patch yesterday.

If the iOS 14.4 patch is messing with Zwift, we’d obviously like to verify this is happening from more members.

Shuji,

Thanks for the response. I haven’t run zwift on my ipad since 1/26 other than a quick logon to check the ios version, which is currently 1.0.61590 . I just updated the ioS software today to iPad 14.4. So, when the errors occurred on 1/26 I was on an older ioS version.

I was planning to run my session tomorrow using my PC, which I just updated to the latest Zwift version, but will instead start with the iPad…for the sake of science. :wink:

I’ll be sure to let you know if the errors continue.

Thanks,

mb

@MaryBeth_Vellequette
For science! :nerd_face:

FYI - when you have Zwift installed on multiple computers - it’s crucial that you are logged out of all of them before you start a session. That’s done by saving & exiting (or trashcanning) each session. On iOS and Android, just swiping the app into the background doesn’t terminate the session as far as the server is concerned, and this causes problems.

To clarify, is force quitting the app in iOS sufficient, or do I need to completely log out of the actual app?

mb

@MaryBeth_Vellequette
Excellent question! For those reading along - there is a distinction between force-closing an app and swiping an app into the background.

The Zwift server can’t tell the difference between you force-closing the app on purpose vs the app crashing unintentionally.

So trashcanning a session (or saving & exiting) are the best ways to make sure you log out cleanly.

OK. I always save and exit (or trashcan) when I am done, so I should be good to go. Thanks for the clarification!

@MaryBeth_Vellequette: I have found that even if you save or trash can a ride on an iOS/iPadOS/TVOS device it still helps to then force-quit (swipe away) the app after exiting. This seems to solve a number of potential issues, for some reason. (Same for the Companion app after each use. Well, I actually do this before each use.)

1 Like

Yes… For iOS and iPad, force quit is exactly what you want to do after you finish saving your Zwift ride. The same applies to the Companion app.

1 Like

You can never be too careful, can you?? Will be more diligent/conscious of it from now on…

Shooj,

For my secondary question…is there a reason that despite the Zwift app knowing exactly where in the workout Zwift quit, it brings me back to the very beginning after each restart? Or am I missing something? It really is a PITA to skip a ton of blocks to get back to where you left off.

My computer froze mid ride. I have forced closed it and restated Zwift. The ride cannot be rejoined. The fit file is there but it says in progress. How do I recover or load manually?

You can’t recover/upload @ Zwift, you can only upload to Strava, TP, … - unless you are on ATV.

https://support.zwift.com/en_us/your-history-and-fit-files-SJbHywdNH

Thanks. I’ve tried this but it says the fit file is malformed so can’t upload. It shows in Zwift although I can’t see any data behind but also can’t load to strava due to it being malformed.

Try fitfiletools.com, I had some success repairing malformed fit files. Be careful with date & time stamps, there were some problems.
Do not exactly know what, did not use it for a long time.

Hi thanks again. Tried that too. Still no luck. Pulled it direct from Zwift too. Tried renaming it too. Odd it’s there in my Zwift profile but no ability to update or upload to strava.