Won't Find Speed Sensor Via Bluetooth

New to Zwift. Tried it on my android phone for a fortnight, it worked great but was way too small. So I bought an android tablet. Zwift on the tablet will not find the speed sensor via Bluetooth.

Ive tried other apps to test and the Bluetooth finds the sensor fine. So it’s not the Bluetooth and its not the sensor.

Its the same version of android on both. But not the same version of Zwift. The tablet has the lastest one, the phone was from 2 weeks ago.

Im out of ideas and pretty peed off with the whole thing. Has anyonr got any suggestions so I can actually use it?

Have you tried turning off Bluetooth on phone then try to pair the tablet

Yep. Tried that. Still wouldn’t have it.

Hi i use my samsung tabs6 and also my mobile samsung s10 connected via a usb/HDMI cable to a tv in the garage works great and i do re install every month and update if required

When you installed the Zwift app on the tablet, you should have been prompted to allow permissions to Locations. If you didn’t allow that - Zwift can’t access your Bluetooth radio.

Depends somewhat on your Android version & device manufacturer, but go to your Android Settings > General > App Permissions > Your location > Zwift, and verify that it’s set to On.

If that’s on - most Bluetooth transmitters create 1:1 connections with a receiver. If the sensor’s signal is being picked up by something else first - that’s a common reason why the Zwift app on your iPad can’t see it.

Are there apps on your either your phone or tablet that’s running in the background sniffing for the sensor’s signal?
Garmin Connect / Wahoo utility / Saris / other sensor manufacturer’s app
Strava or other fitness apps
The OS of your phone or tablet - don’t pair your sensor to the OS itself - you want to pair to the Zwift app.