Win App not working - 2021-05-19


Today I’m getting “The remote server returned error: (400) Bad Request” in a popup window when I try starting Zwift on my Windows computer and pressing “LET’S GO” orange button. After a few tries, I also experienced the " Zwift Something went wrong. Please try restarting Zwift." in a white window - no “WELCOME!” window appears in this case at all. I’m running the latest version of Windows 10. The internet connection is working fine - I’m writing this message from the same computer in a browser, so also the login works.

Reproduction steps:

  • Login into Windows 10 (last updates).
  • Start Zwift (Auto-Start is turned off).
  • The “WELLCOME!” screen appears.
  • Press the orange “LET’S GO” button.
  • Here a popup appears with the message “The remote server returned an error: (400) Bad Request.”.

Expected results:
I’d expect the Windows application to start, so I can ride.

I’m looking forward for a fix of my problem.

Best regards,

When did it last work? Is it a work laptop? A firewall could be blocking some of the ports/sites that Zwift needs to work, and having general browsing access on the laptop doesn’t tell you anything about those Zwift specifics.

I had this message on my system last week, I don’t think it’s a port thing related to work PCs. Just an extension of the launcher errors that have been going on for weeks. :confused:

1 Like

Trying to help by minimizing troubleshooting - I’m a software developer, so I can assure you the computer was fine, firewall wasn’t the issue, nor the internet connection.

Last time it worked was yesterday morning between 6:00 and 7:20 (CEST). Today it also started working after 5:55 (CEST), but before that it didn’t work between 5:35 and 5:55 (CEST), which was very annoying, as this was my planned slot for the workout.

I checked Zwift status page and all services were supposedly working.

Dave may well be right that it’s a launcher issue. But given the intermittent nature of this problem, I still wonder if it’s port related. You say that the internet connection is fine, but what are you basing this on? It’s possible your ISP has been messing around with what traffic they allow through.

I’m admittedly clutching at straws, but just about everyone else has been Zwifting without problem, so your issue seems to be specific to your setup (including your route through the internet to Zwift’s servers and the various required ports).

I have to admit, I didn’t do a Wireshark or similar trace. I can just tell you, various services I’m using as a GCP Cloud Architect were all working.

I’d suggest just closing this item with CANNOT REPRODUCE and if it happens next time, I’ll do a bit more investigation about it.

May I ask where Zwift is hosted? Are you using one of cloud providers like AWS, GCP, Azure, or are you using your own datacenter. Are you using any single purpose specialized services like Auth0, maybe Firebase, etc.? I’m asking this, so I could do a better diagnostic next time.

And thank you for getting back to me and doing your best to help.

Best regards,

Have you tried the previous solution, which is to clear Internet Options?

Zwift uses AWS. I can’t remember in which region.

You should follow Dave’s suggestion too.

As I’m using multiple browsers, using Chrome as a default one. Also, I’m using multiple user profiles in Chrome as well.

As I wasn’t sure which one to use, I just cleared last 1 week of history from my personal profile in Chrome and cleared everything in Edge and rebooted the computer. I’m not really sure this is what the clear Internet Options refers to.

Internet Options is the old, standard place to clear things up … still used by Internet Explorer.

Zwift, apparently, uses IE for the launcher to make the connection to your account, get logged in and get everything ready to run before handing over to the app itself.

In a lot of cases like this one (there are other threads going on the forum) clearing the IE cache (Internet Options) has resolved the issue. It isn’t related your own browser usage, just the usage of the launcher.

1 Like

Thought you are a software developer? :wink: The Zwift launcher uses IE to manage login. Clearing Internet Options deletes the cache and stored credentials and usually sorts launcher issues. You don’t need to go into IE itself, you can do it as follows:

  1. Close Zwift completely, including the launcher from the system tray (right-click and Exit).
  2. Hit Start and type Internet Options and select it.
  3. Down the bottom under Browsing History hit Delete…
  4. Tick all the boxes except the first one and press Delete.
  5. OK out of Internet Options.
  6. Start Zwift and try again. You’ll need to log into the launcher again because you’ve now deleted your credentials.