Zwift Login Issue: Failed to login. Check Internet Connection

Hello,
I upgraded Zwift on my Windows 10 laptop this morning. Since then I receive a ‘Failed to login. Check Internet Connection’ message.
My internet is working perfectly ok. I can open other pages and applications.
Zwift was working fine until the upgrade, so appears that the upgrade caused an issue.
Anyone else experience this and how did you overcome it?
Thanks,
Jason

Hi @Jason8824_Corbett, I just logged in on my win 10 laptop without issue. Maybe try powering off your modem/router/wifi and turning it back on after a minute.

Also, where are you located in the world? Sometimes this is location specific if your ISP isn’t able to communicate with Zwift.

1 Like

Hi Mike,

Yes, I have powered off/on the router, rebooted my laptop and still no change.
All other connectivity works ok, with Zwift being the only exception.

I am based in Ireland. The application works fine on my iphone connected to the wifi network also, but not on Windows 10 laptop.

Thanks,

Jason

during the update this week, a new launcher was installed. Do you remember giving Zwift permission to install the new launcher? Right click on it in the system tray, should have these version numbers:

image

How far are you getting into Zwift before you see the failed to login message?

Yes, it was this upgrade that caused the issue to start occuring.

The error message appears on launching the app.

Is there anyway of getting the old installer reinstated?

I don’t think so, you may need to do a reinstall of the launcher only.

@Dave_ZPCMR, there is an easy way to force the launcher to reinstall isn’t there?

Update

I turned off the router again and connected to the internet via a mobile hotspot, but unfortunately the same issue.

Therefore, this is definitely a Zwift issue and not an ISP issue.

Any further help would be really appreciated.

Thanks,

Jason

Usually you’d just run the latest installer. However the game is currently pushing it out anyway. To reinstall you’d need to install an older version, then the latest one again. It can be done without uninstalling the whole game. Not sure that it’d help with this though.

1 Like

I would try uninstalling Zwift completely and reinstalling it.

1 Like

Yep, I have done this also

Where exactly does it fail, in the game itself after the blue loading screens have gone off? What happens when it fails to log in? Can you enter the credentials manually and it still doesn’t work?

The blue login screens all flow through normally. Previously, it would load straight into the game, but now I’m presented with the login screen with the aforementioned error.
I can enter the details manually but the same error is returned. I’ve tried resetting the password also, but again no joy.

Very frustrating

Sounds like a firewall issue tbh. Your credentials work, else you wouldn’t get in the launcher and it wouldn’t work on your phone. Something is blocking your connection to the Zwift servers.

If a FW issue, there must have been a change on the Zwift connectivity side, as nothing has changed with my isp. The issue arose post upgrade.
I’ve also tried via mobile hotspot and the same issue occurs, so a different route out but still no connection.

Any idea how I can check connection to Zwift?

I can log into the Zwift account via web portal, would that not sit on the same servers as the game?

Trying via mobile data wouldn’t make any difference if the blockage is within your PC’s settings/config. The game working fine on your phone suggests there’s no issue with your ISP. So I’d suggest it’s something your PC is doing. Game servers are probably different to the website, yeah.

Some stuff to try, with Zwift closed from the system tray:

  1. Clear out Internet Options and reset the security zones to default (shouldn’t matter any more, but who knows).
  2. Delete the contents of the Zwift folder in %temp%.
  3. Delete prefs.xml (which will obviously mean setting up your preferences in the game options menu again, if it works).

This has been bugging me big time last few updates. Same situation as you - work laptop, everything with my network fine, phone app works but not laptop.

I’ve contacted Zwift and had three advisors help to no avail. Restart everything, reinstall app and launcher, delete temp files etc etc.

In the end, after stumbling on a few threads noticing it’s people with work laptops having this issue… I made a new user account on my laptop, that doesn’t connect to my work domain (using personal email vs work)… And it worked!!

The good news: Can now ride.

The bad news: Tour of fire and ice tomorrow.

Would be curious and hopeful this works for you?

1 Like

Can’t login to gaming. Ambassadors suggested resetting Windows Explorer, and if that didn’t work, uninstalling gaming app, deleting some files from c:, and re-installing.
I feel like the GEICO robot: frustration mounting!
I’ve been using Zwift since shortly after beta. Perhaps I’m just too stupid to continue.
Any suggestions?

I’m having this exact issue, it’s so frustrating. I’ve been using my new Mac (work computer). And it’s been working flawlessly until about a month ago.

I’ve tried everything mentioned below - but nothing works. I can login on my Iphone no problem.

Please help :pray: