Zwift won't load - help!

I am suddenly unable to open Zwift on my Windows 10 PC (Lenovo Yoga 520). I’ve had no Zwift issues whatsoever for 2+ years before today on this laptop.
I able able to enter my username and password then the screen becomes:

HTTP 400 Bad Request
The webpage cannot be found|
Most likely causes:

  • There might be a typing error in the address.
  • If you clicked on a link, it may be out of date.|
    What you can try:

Retype the address
Go back to the previous page.Go to the main site and look for the information you want.
More information]
This error (HTTP 400 Bad Request) means that this program was able to connect to the web server, but the webpage could not be found because of a problem with the address.|

Anyone able to help?
Have done a clean reinstall of Zwift, ActiveX and Java seem to be enabled in IE.

Thanks!

Try resetting IE/Edge

1 Like

Click on Go back to the previous page. and it should reload and all will be fine.

But as Paul said you may want to reset IE/EDGE.
" I gave up on resetting IE and just click Go back "

1 Like

There’s no option on the launch page to go bak - it isn’t a link.
When you say reset IE, what do you mean? Sorry!

Try this link: https://support.microsoft.com/en-us/help/17441/windows-internet-explorer-change-reset-settings

1 Like

On my PC the go back is a link, it does not happen all the time so I can’t get a screen shot. :crazy_face:

But it look something like this:

Gerrie, that is what I’m getting but nothing happens if I click on the link. Not even getting the log on page now!

Can it be that you internet provider changed a setting and now block one of the ports?

@Paul_Allen what do you think?

Could be.

@James_Little_GDW are you using a Proxy or VPN?

Hi Paul, not using a VPN. Don’t think I’m using a proxy but may be wrong on that.
Sorry to be dense, but is there an easy way to tell?

We have a BT Home Hub and then a TP Link extender out in the shed over the electric cables.

I went back into the Internet Explorer settings this morning -
Internet options > Security > Restricted sites > Sites
and Zwift Laucher was showing under Websites. I removed it and have subsequently not had the ‘white screen’ shown by Gerrie, and Zwift opened.
I’ll try again this evening when back home, but in the meantime my fingers and toes are crossed that you have helped me resolved this.
So many thanks!

2 Likes

That is Awesome @James_Little_GDW

Lets hope it stay that way.

2 Likes

I just got this error for the first time today. I’ve tried to change default browser, clear cookies, cache and see if site is restricted. I can load Zwift from my iPad but not my PC.
Was ready to hit TOW Stage 4 instead been debugging for the last 1.5 hours all to no avail.
Any help would be appreciated.

1 Like

Clear the cache on the OS default browser. For Windows that would be Internet Explore or Edge and for a Mac it would be Safari.

1 Like

Hi Teaco, I also am suddenly getting the same error after runninng the app on my laptop for 1 year with no issue. Have you managed toi solve it ?.. I do not want to rebuild my laptop if I can avoid it .

I went and cleared browsing history, cache and cookies. Besides the default browser, you need to go to Internet options in control panel and clear there too. IE is being discontinued but still has back end control.

Steve

Thank you Teako, the extra step of clearing the cache via the control panel looks to be the missing step for me. The ZWIFT app now works & connects cleanly !

I’ve tried all of the stuff above, reset Edge, reinstalled Zwift; still the same error:

HTTP 403 Forbidden

The website declined to show this webpage

|HTTP 403|
Most likely causes:

  • This website requires you to log in.
    What you can try:

[Go back to the previous page.]

[More information]

This error (HTTP 403 Forbidden) means that this program was able to connect to the website, but it does not have permission to view the webpage.

I’ve also had HTTP 400 error.

I’ve just missed by ZRL race, and I’m really grumpy. I’d really appreciate some help.

Thanks

Hi @Jake_Bailey

see this post. Internal Server Error 400 / 403 (Clear your browser)