Why can't I join any races? Very frustrating


(Man) #1

I’ve been trying to join several races the last few days and I haven’t been able to.

I tried to join through the Windows app , but the race isn’t shown in “Upcoming Events” several minutes before the start of the race.

Just now I tried to join the 3R London Loop at 10:20AM and the same thing happened: I can’t see it in the Windows app and nothing happens when I press the “+” in the iphone. The “C” category had 25 participants and I tried to join 10 minutes before the race. The same thing happened with “B” & “D”.

What’s wrong?


(Daren) #2

I don’t know why it would be, but have you tried joining from the Zwift website?


(Man) #3

I don’t see it there.

I’m trying to join this race right now by clicking on the “+” button, but I can’t either. The race hasn’t started yet. This sucks.


(Daren) #4

I don’t see any 1 lap Greater London Flat races coming up today that start at 5-past the hour.

As a test, just try joining any upcoming event on the website.


(Man) #5

I was able to join an event called “Movie HQ Virtual” from the iphone, and it started 3 minutes ago:


(Daren) #6

Odd that it’s some events and not others.

Maybe try a process of eliminations. Register/unregister for a range of events and see if there’s any pattern. Is it only races? Is it only group C? Is it only on London? That sort of thing.


(Man) #7

It seems it only happens with races. I was able to register to “BTX Group Ride” but I cannot register to “ZHR Contre LA Montre Atlantic TT”.

Considering I’m paying for this, It’s very frustrating that nobody from Zwift has offered to help.


(Kevin) #8

I know on the companion app there is a filter where you can choose the type of events you want to see (group ride, group workout, race, or fondo). If you had race unchecked it wouldn’t show you any races. I never use the windows app but is there something similar there? Could the problem be a filter set in the companion app carrying over to the windows app?

I wish I knew the solution but that’s all I can think of.


(Daren) #9

If you haven’t already, open a support ticket:

https://support.zwift.com/


(James) #10

I suspect a time related issue on your phone and the event has already started.
You were able to join an event with “late join” active, so I’d narrow that down to a 30 minute offset. Are you in a :30 minute timezone? Is your time set manually?


(Daren) #11

I wondered about that, but all the screenshots seem to show times that are ahead of the event and I assumed it’d be synced by the network provider. Does seem the most likely cause though.


(James) #12

If you manually change your phones time you will see all events from that point on, as if they were about to start. The companion app asks for data from the local clients date/time.