White screen at startup...again

There have been numerous threads on this in the past I can see from search, but the issue never really affected me…until now. I’m on a completely up to date Windows 10 dell xps laptop

Looking through those threads, there are lots of suggested fixes:

  • just press ctrl-r and wait a bit in the blank white screen for the UI to paint (didn’t work for me - dwfm)
  • make sure all instances of the launcher are closed via task manager before launching (dwfm)
  • uninstall and reinstall (dwfm)
  • uninstall and remove all left behind files (like in Documents), then reinstall (didn’t work for me - dwfm)
  • make sure all your display drivers are up to date (they are)
  • try installing the zwift hack auto login script (dwfm)
  • start edge and just leave it minimized before launching zwift (dwfm)
  • look at the logs (they don’t show anything really useful tbh)

So what are we supposed to do? I just restarted my subscription to zwift today - I won’t be sticking around if it doesn’t work!

I tried reaching out to support, although that supposedly isn’t an actual support person but rather an “ambassador”, which sounds like some kind of unpaid volunteer. Thought I’d post here in case somebody can point out something I haven’t tried yet.

Hi @Sir_John_A_MacDonald

Welcome to the Zwift Community forums.

I know technical issues like this can be frustrating. It sounds like you’re already on the right path by talking to one of our Zwift ambassadors. If they weren’t able to help you directly, they would have forwarded your message to our technical support team who will take things from there. For more complex and unique issues like this, the best course of action is to work with our technical support team.

I sincerely hope that the resolution is Zwift and easy!

Thanks Terry. Can you tell me when I should expect to hear back from a support person? The message mentioned most are answered within an hour and I’ve heard nothing 7 hours later. Just looking to have my expectations set. Thanks.

Not ideal but i always fine point two works fo rme when i get the white launch screen.

  • make sure all instances of the launcher are closed via task manager before launching (dwfm)

Well for those following along here, support asked me to try creating a new profile (basically a new user account) and try launching with that. That worked, but it’s not really a solution for me. After that, they went back to saying it must be my firewall, which is odd since the firewall has the exact same settings with my main account as it did the newly created account.

They’ve since said they’re aware of the issue, thanks for reporting it, and closed my support request. So no zwift for me. One hopes they implement a real login screen instead of just a hosted webview of one.

I hear Rouvy is quite nice…

and killed the launcher process and trying again still does not fix it?

Unfortunately no, it doesn’t.

very odd, what about on a different network if you tether to phone?