When I click "join event" I am not brought to the start area for the event I want to join


In the last two evenings I have tried to join some races and ended up missing them for an unknown reason to me. I make a point of warming up and trying to join the event 10 to 15 minutes before I am due to start.

At 15 minutes, I click on the blue join ride. On both occasions I am not brought to the start corral. instead I continue riding on the course where ever I was previous to clicking the blue button and generally alone…One thing that does update is the ‘riders nearby’ list. it updates and includes the number of people who in the event I am trying to join(?), but I can’t be sure.

I looked briefly through the forum here, but did not see anyone with a similar issue. Can someone point me in the right direction for help?

I removed Zwift from my Mac, re-downloaded the zwift program and it appears to be working now.

1 Like

This is an older thread but I am experiencing the same problem. I sign up for a meetup. Start zwifting ahead of time. 5 minutes before the meet-up starts I press ‘join event’ and… nothing happens! I just stay in the world/route where I am. Rebooted several times but to no avail. I have now missed several meetups. This is so annoying.

I run Zwift on a iPad. Anyone any suggestions?

I’m on an iPad too, and used to have this issue. I would double tap the home button and swipe the app up to fully close it. Then reopen it, spawn wherever the default was, and then click the join event button. That always worked for me. But I always had to go through the process of opening the app, doing a spin down and then warming up somewhere, completely closing the app, and loading it up again and o join the event. Annoying.

I haven’t had to do all that for a while now. Usually, I can just go on the one time. But I also don’t warm up on a course. I use the spin down (with the 5-10 minutes to warm up my trainer first) and then sitting in the pens as my warm up. So maybe it has to do with riding in one of the worlds first?

I also know that I do have to spawn in a world before I can join an event. If I click the Join Event button on the Home Screen, nothing happens. I have to spawn in a world first (I don’t ride anywhere after I spawn), then join.

And then the more obvious … always make sure your app is up to date (I’m sure it is, just covering my bases).

Good luck, and Ride On!