Auto join event failed to work


I was due to ride in the 11am GMT group workout today and was logged on in plenty of time and riding.  I didn’t receive a notification the event was about to start so was unable to join.  Is there a way to join an event in the case of the notification not arriving whilst riding ?


Moving to Tips and Troubleshooting Forum

There should be a button to Join Event in the bottom-left corner of the screen, unless that’s changed recently.

That being said, we’ve also received a couple reports about the prompt not showing up, and I’d be interested in seeing your logs. I’m creating an email ticket for you from this post - keep an eye on your inbox for more information.


1 Like


I’m having the same issues lately. I can only join events when I select them on the laptop before starting the activity.

Once the activity has started and I try to choose an event via the zwift mobile link, I never get the join event button on the laptop.

Kind regards,


Today I tried to join a couple of events and failed every time. 

I tried to select an event, start riding a couple of minutes before the event but no pop up was showed on the screen. 

I tried then to select an event and wait on the main screen without starting the ride but nothing happened. I am confused. 

Same problem here, trying to join a race but the “join event” icon is not showing on the bottom left of the screen, very frustrating when you’ve done a warm up!!

I had the same problem today - it was my first attempt at joining an event that I had registered for on mobile link a few days earlier.  I use an iPad for the ride and have mobile link on my phone but no prompts to join the ride.  I came back to the rice screen and chose an alternative ride that was due to start but the same thing happened.

Is there a solution to this?

I’ve not tried to join an event for a while but the last time I did I think I managed to resolve it. Double click the home button and then swipe up to remove any existing Zwift pages. (Or just remove all existing open apps) then restart Zwift and Click on the event you wish to join, press ride and within a few seconds it should say join event. For some reason if you have an existing Zwift page open it wouldn’t work.
Be interested to know how you get on and if this works for you.
Kindest regards

1 Like

Same problem here. Joint even via the mobile link and started to ride in Zwift using my iPad. Never got the information that the event is about to start so that I can click the button to “teleport” to the start.

Any feedback from the Zwift team to this issue?

Richard’s suggestion worked - close the apps before starting a new session. ZML still seems a bit glitchy at the moment but I tried joining an event that had just started via the ride screen and it took me straight to it.