Impossible to start a time trial


I tried to do the zwift friday time trial, but impossible to go to the start !!
I was inscrit but nothing. What secret procedure do I ignore ? I didn’t use the secret magic words ??

Hi @sebastien2845_hanrar, the process is the same for joining any other race or event on Zwift.

How did you sign up for the event? Were you on Zwift riding in one of the available worlds prior to the start, waiting for the “join” button to appear in the lower left side of the screen?

How to start a event. Zwift For Beginners - Joining a Group Race/Ride/Workout - YouTube

I’ve had issues with this recently (Apple tv) sometimes i don’t get the join event pop up in the bottom left, seems to work if i unselect the event i want to do then re select it

I also have a feeling that joining events on AppleTV has gotten glitchy. Sometimes I log in as usual, start a ride and wait for the “Join” button - the button appears briefly but disappears as soon as I pick up the remote. It appears again briefly et.c etc. - but it won´t let me join my event, I´m not able to select it. I log out, deselect the event in the companion app, select it again, start Zwift again, and finally it works. This happened twice in the last few weeks (never before), no idea what was going on.

Thank you for your answer.

I was riding in one of the available worlds, but no “join button” appears !!
Usely, it appears 30 min before.

Impossible to go to the TT race (time trial).

Thank you but I’m not a beginner. 78 races. I think there is a big bug for me.
I will try again soon.

I had to start some ware. :ride_on:

As @sebastien2845_hanrar mentioned that can happen then unselecting the event and re selecting on the companion app usually fix the issue.

There seem to have been a lot of complaints of this nature recently. A bit more glitchy than usual perhaps. I have had a delayed join button in the past (not recently) and found that cancelling and rejoining the event (on CA) usually worked.

Question: How are you signing up for the event (in-game or via companion app or some other application)? And what is the order in which you are performing tasks?

I use ATV and what I have noted is that (a) definitely better to sign up using the Companion app and (B) if I sign into the game and THEN select an event in the Companion app I never get the ‘Join Event’ button.

I’m not saying that you aren’t experiencing some bug, just saying that my experience is that if I join an event in the Companion app before starting the game I have never had any issues with the ‘Join Event’ button appearing.

1 Like

I’m going first in game and after I join the race in game, and after I go to watopia to warm up.

I will try your way. Thank you.

Please let us know if this corrects the issue you are having. Always good to know if a solution works, or not.

I tried a few hours ago and it worked. Now I know : I have to register on Companion first (I never did that).

Thank you for your help.