What the

I’ve tried for almost an hour trying to get zwift to work. Unplugged. Reset. Using a Wahoo kickr 5, Apple TV, iPhone, iPad, and all the tools to ride on Zwift. Wtf!!!

Had this issue before. I told myself it was a one off. Now it happened again. I don’t want it to happen a third time.

Nothing works.

I had to stop. So frustrated. I couldn’t put my ride in. Zwift fix the bugs. You’re a big boy company. Bad business. Bad business model. Bad management. Your CEO is for crap. Focus on the must haves versus all the nice to haves. And fix the bugs.

Anyone got any ideas?


Dear developer: Please solve this unspecified problem. Thanks.


Are you running the game on all these devices at the same time? That’s going to cause lots of issues. Force close Zwift on all devices and focus on just using one of them.

1 Like

I am not running all these devices at the same time.

I only use my iPhone for the companion app and Apple TV. Sorry to air my frustrations.

My setup
Wahoo Kickr 5
Wahoo HR armband
Stenzo steering (connected to the companion app)

Each device is connected.

I tried riding on different workouts with the same results. The avatar is moving and I’m spinning on my bike nothing I registering. I’d reset the Apple TV, unplug my kickr, and close the companion app. But the issue would continue.

The Apple TV Zwift app has been problematic.

I’ve unplugged everything, hoping tomorrow the problem has resolved itself.

Do you force close the app on ATV after each ride?
In pairing screen, when you pedal, do you see your watts and cadence?

I’m confused as to what the issue is?

Your avatar is moving?

What’s not working?

1 Like

Yes, to both.
Yes - I force close it by swiping up. I’ve done everything possible. I’ve hard reset the Apple TV, deleted the Zwift app from the Apple TV and iPhone, deleted the Companion app, unplugged the Wahoo Kickr, and I still have the same issue.
Yes - in pairing mode, cadence and watts are connected and show information on each when I start pedaling. Once I enter training mode, the cadence and watts are not showing on the screen. This also includes the HR monitor. On the Companion app, the same thing happens when I enter training mode, no cadence, no watts, and no HR.

I’m going to reinstall all the apps on each device. I will throw my Apple TV in the trash and only use the iPad to connect to the TV directly. I may consider purchasing another Apple TV, but I’ll wait.

By training mode do you mean you are doing a workout? What happens if you just load a random route and free ride, or ride with a pace partner? Does it work then?

Wondering if there is an issue with the trainer when trying to use ERG mode in a workout?

Training mode and workout are the same for me. I’ve had issues across all the different modes (meaning workouts, pace partners, group rides, and free rides). My ERG works fine I don’t experience any issues when I ride on Rovy and the wahoo apps (RGT and workout).

this may take awhile to sort out - I suggest you contact Zwift support as i have found them helpfull - sorry they won’t let me post the link (so maybe not that helpfull)

I wouldn’t chuck your apple TV in the bin if you’re then going to consider buying another one. That seems a little silly.

For what it’s worth, I have no issues with ATV. Using Tacx Neo 2 and Garmin Dual HRM.

1 Like