Weird ITT Bug

I tried to join the ITT race scheduled for 9pm EST today (Nov. 29, 2022). When I came into the start pens, it said that I was going to be released in 1:29, and it just stayed at 1:29 for about a minute, at which point it counted down to 1:28. This was my first time trying an ITT. About a minute later the timer had counted down to 1:27. (I actually thought, maybe it means an hour and 27 minutes, so I asked in the chat, and people thought I was joking. Also it wasn’t counting down at exactly a minute, more like 45 seconds for each “second” from 1:29.)

As this was happening, my avatar kept drifting backwards relative to two other avatars near it and then suddenly jumping forward to be next to them again, over and over again.

I then tried exiting the race, but was unable to rejoin (have you turned it off and on again?) because at this point it was about 9:02 pm, so the event was no longer showing up in the UI. (Perhaps with TT races, they could linger a bit if you are signed up for them on the front UI so you can get back in if you were in the pens?)

I’m running Zwift on a Mac, and the client is up to date. I’m happy to get more system information and/or logs if any are relevant.

I’ve seen others get this issue (@Craig_D_Mart ) for some reason if gave you a 90 mins wait time. Maybe worth raising as a bug.

If you had exited and re-entered the pen before it started that probably would of worked.

Thanks @Gordon_Rhino-Racing .

I did already bring this up in this thread here last week:
https://forums.zwift.com/t/start-time-issue-tt-event/594549?u=craig_d_mart

Had this bug today as well. Also noted that onscreen message prior to joining the event indicated a start time in over an hour despite the companion app indicating start time in just a few minutes; should have took that as a hint I guess.
Signed up for event about 10 minutes ahead of time which was even a few minutes before the first rider would have gone off.
Trying to post a waiting screen grab, note the 1:21 is apparently hours:minutes

I’ll comment that closing Zwift and re-opening fixed this for me, but if it’s like the Paris start bug, that wasn’t fixed by that all the time.

@James_Zwift

Thanks all - be good to know with O/S this is happening on. (I know John said MacOS)

I was on Windows, not sure on @Chris_Panza.

Like I said, based on the chat, it happened to multiple people the same night it did me (I got a scarcely-deserved gold trophy riding up a category from what CE and ZwiftPower give as minimum)

I’ll see if I can get in touch with any of those folks and ask them

Mine was Windows 10
Signup for event was done with the companion app on iOS - iPhone

I’ve had this happen twice now when going to the pen for the Zwift TT club races.
Tonight I decided to let it be rather than to quit and rejoin just to see what would happen.
It did not put me in the pen so missed the race.

Windows 10 and used the Companion app on IOS to sign up.

I’ve flagged this with the team - it is a US holiday today though.

1 Like

So we think that this only happens when you sign up to the event, using Companion App, when Zwift is already running.

If you signup to the event:

  • Using the Home Screen
  • Using ZCA before you start the game

We think that this will work as a workaround whilst we fix the underlying issue.

1 Like

That’s what I did James.
Was warming up in Zwift (actually testing the legs to see if they were up for it) and signed up for the iTT with Companion app.

Another known workaround, if you enter the event and get the wrong start time and are placed at the back of the paddock, just exit the event and go back to the home screen.
When you re-enter the event, you will be put in the correct position of the paddock with the correct start time.

2 Likes

That’s what I did. I didn’t notice that the time was wrong for a while though, I can see people missing their time.