Strange results after WC TT

Just finished my first event which was the C group WC TT. It looks like quite a few of us were given odd results. On the results screen in game it was illegible.

Looking at Zwift power it has our times as 23:59:59. Think my actual time was a 48.x

image

This is a glitch that has been around for a while now. I’m not exactly sure what causes it (or why Zwift have not fixed it) but I think it has to do with going to an event directly from a previous ride, as opposed to ending and saving the prior ride, and force quitting Zwift if you’re on an iOS device, and then starting a new Zwift session for the event.

I believe the glitch is caused by using the Late Join feature.

1 Like

Yes that’s what happened. From the main screen I had joined the event (windows pc) on the top right but when the timer ran down I couldn’t work out how to join it.

I clicked ride and then from there once loaded it asked me if I wanted to join the event.

Won’t do that in future once I work out how to join the event directly. Once the timer ran out on the event listing the only option on it was to leave.

Thanks

Think I have worked (read) it out. Register for event, then start a ride and then click on the join event in bottom left anytime 30 mins before the start time.

Basically what I did but not after waiting for the event start time to actually pass!

Is that right?

That sound correct. You can ride around until it is about 6 mins before the event then click join event. You will than get transported to the waiting pen where you can warm up a bit more.

Good luck and enjoy.

Thanks Gerrie

I tried to join the WC ITT-group C, it registered that I was going and the event count-down to join started, but when I clicked “join”, nothing happened. I wasn’t transferred to the course or start line. The start time came and went - nothing. I’ve done an ITT before (not WC) and it worked fine.
Not sure what happened.