TT event time not matching time on the screen


I am wondering if anyone else has had the problem where the TT event finishing time (in this case the British Cycling TT events) is not matching the time on my screen when I cross the line.

Tonight, my finish time for the 16.1km was 34:22 on the screen but the results time on the companion app shows is 35:16

I noticed this last week but didn’t note the timings however the 2 weeks ago when looking back, the screen time was 31:41 on the line but the companion results time is 32:14.

Any help on understanding this would be good.


I have had that happen to me on the Bologna TT course more than once. But that was around the time when the course was first released last year and i haven’t tried since. Officially results added about 20 seconds to the time when i crossed the line. Not sure why that is.

Thanks for the reply - Nice to know it has happen to not just me.

I’m not sure if the lead in time from the gate area to the official start line is being counted as part of the total time. That is the only way that it can count extra seconds.

I will be doing an official TT this week so will confirm the timings

Hi Phil, same happened to me on BC TT’s and also “Events” with reported results, recently they’ve been +20~35secs, Any answer’s would be appreciated.

same happening to my son too. He worked really hard to get under 28mins last night on the BC TT and got 27:33 (I think from memory) and then the result say 28:13. He was a bit upset. (he’s 9).
I’ve messaged Zwift Support to ask for any explanation. It’s not the first time it’s happened either.

The longer one is the event time which starts when the countdown gets to zero in the pen. The shorter one, in the HUD, starts later once you are exiting or have exited the pens, and is often (but not always) indicated by a double white line on the road. That is when data capture for the fit file commences.