Weight setting wrong on Companion app

Starting my TTT yesterday, I could not do more than 1W/KG. Checking my weight setting in the Companion app it somehow changed to 890 000kgs!!! Let’s say I somehow made this change, I am now trying to set it to 89kgs in the Companion app, but it is now stuck on 8 900kg, despite being 89kg on my Zwift profile on my PC. Any idea how I can correct this?


Have you tried clearing cache/deleting and reloading Companion App? I’d also try adjusting the weight in the Zwift app (under Settings menu) rather than the web and see if that filters through to a reloaded CA.

I checked my weight in CA (android) and made a change and everything looks normal so suspect its a one-off gremlin.

I have the same problem…i didn’t save the changes but it showed 8000kgs.

Ok, it seems the decimal point is missing. I have just changed the weight on my Zwift app to 89.01 and it now shows as 8901 on my Companion app. Also if I know cycle it shows the correct W/KG. So the decimal is just missing…but otherwise working fine.

Hopefully one of the support folks that cruise the forums, or @shooj, can feed this back to the dev team.

Same in my companion app

Perhaps try to switch to imperial and enter in equivalent lbs in the Zwift app or companion app?

Hi @Ernst_Retief_8401

Thanks for reporting this. It look like this is an issue with decimal formatting when using a comma “,” as separator as apposed to a point “.”


Unfortunately for Zwift, the comma decimal separator is the standard in a large number of non-English speaking cultures, if not the majority.
My devices running in French or German default to the comma. I recall that the Apple TV in French only allowed the comma.
Let’s hope that this is corrected soon. The less observant victims of this bug will find climbing rides nigh on impossible! :woozy_face:

Edit: Hey! I’ve just twigged that the latest version of Companion now allows bodyweight to be entered in Companion with two decimal places. Up until now, this was always limited to whole number kilogrammes in Companion, while it was possible to enter decimal place values in the pause menu profile. Interesting!

1 Like

I’ve been trying to reproduce this issue on my devices (iPadOS and PC Win10 for Zwift, and iOS for Companion), and changing Companion and Zwift languages through French, German and English.
So far, I haven’t run into this issue. :man_shrugging:

Changing my weight to 81.07kg in Companion while I’m not in a ride makes my weight in Zwift (as seen in the profile under the pause menu)… 81.07kg. Changing my weight in the pause menu to 81.04kg is then reflected as 81.04kg in Companion after I close that app and reopen it. (The close and reopen might not be necessary; maybe it just requires some time).

Even when running Companion or Zwift in French or German, on devices where the system language is French, there is no longer an option to use the comma as a decimal separator, but the decimal point is now available.

I’m running Companion in iOS, and both Companion and Zwift are all latest versions. @Ernst_Retief_8401, @DejanPresen, and @sjaak_van_Haasteren are you on Android or iOS? All latest versions of Zwift and Companion?

I wonder if the issue described in the OP was the result of having a weight that had originally been saved with a comma separator in Companion running on Android being misinterpreted by the game following the latest Companion update. Hopefully, for those afflicted, rebooting Companion and Zwift, and manually re-entering the weight with a decimal point in Companion will solve the issue.
If not, and Companion is running on Android, that’s where Zwift needs to be concentrating its resources to correct this…

Companion on Android.
The issue is only visual…it’s not showing comma. But if you change the weight with Companion like 80.1kg it will save OK but when you check again it will show 8010kg…

1 Like

Hi @Ernst_Retief_8401
Height and weight changes will not save while you’re in an event. Were you already in the TTT pen when you were trying to make the change?

Once you’re out of the event, you should be able to make these changes, either in the Companion app, or on your profile web page. Would you verify that works?

Regarding the decimal point vs comma: I’ll ask about that.

Ich habe das gleiche Problem:
Wenn ich 80.00 kg eingebe und Speicher und anschließend wieder rein gehe - alles in der comp. App - dann wiege ich 8000kg gehe ich raus und speichere erneut, statt zu verwerfen und gehe anschließend wieder rein, wiege ich 800000kg. Ein weiteres speichern geht dann nicht mehr, weil offensichtlich mit jedem speichern 2Nullen drangehängt werden und der NULLVORRAT erschöpft zu sein scheint.:-(. In meinem PC-Profil sind jetzt 8000kg hinterlegt, also immer das in der App durch 100.
Achtet darauf, sonst fahrt ihr bei dem Gewicht rückwärts von AdH den Berg runter.
Habe jetzt im Profil wieder 80kg eingestellt und prompt waren in der App 8000kg.
Ein Komma kann in der App nicht eingegeben werden-es ist ausgegraut.
Ride on

With US regional settings, no issue with companion App (on my Android tablet, no issue there).

With FR regional settings, the separator is disregarded and hence the weight is multiplied by 100 (on my Android phone, issue there).

This is a basic coding issue where regional settings have not been taken into account.

If this affects your ingame weight (i.e. this is not only a visual issue), you may try the workaround to change it using my.zwift.com, without opening the companion app afterwards.

So far, everyone affected seems to be using Companion on Android, right?

That’s correct for me - 83,00 kg on iPhone, 83 kg on zwift.com and 8300 kg on Android.

1 Like

That is correct

1 Like

Ich hab jetzt im Android-Smartphone zwar 8000kg stehen, im meinem persönlichen Account auf Zwift stehen 80kg. hab heute trainiert, die w/kg wurden normal berechnet.
Insofern Änderungen nur über den Accout vornehmen, da man bei Änderungen übers Smartphon auf speichern gehen muss und dann glatte x100kg mehr wiegt.
lt. support sind die leute dran am problem :frowning: :slight_smile:

Running Companion App on Android. Same issue here, it won’t even allow me to type in comma :frowning:


My companion app is showing 8400kg instead of 84kg. When i try to correct it i can’t save my weight.

I tried to reinstal companion but didn’t work.

My weight at zwift and zwiftpower is correct bur when i start to cycle and put companion on i feel like a turtle.

For now i deinstalled companion but off course i want to use it again.

Help !! !

1 Like