Weight - appel TV

Hello.
Since I ride on Zwift I used PC configuration.
I just ordered Appel Tv.
My first issue : I can’t use “,” for my weight.
As this is not allowed also on companion can someone help me ?


Ride on

Try typing 65.

65kg is working but as I’m competitive rider on Zwift, I update every day my weight.
Until now with PC configuration I was able to provide weight accuracy = 0,1kg

1 Like

strange, my apple tv lets me put in my weight to the 10th. i did notice that by changing between metric or imperial changes my weight slightly

Lucien, I think this is an Apple configuration issue in France. That doesn’t help you much, as the Apple TV limits you to the interface associated with your location and Zwift apparently doesn’t recognise commas in numbers (despite it being the norm in French and German, Spanish, etc. etc.).

I’m in French-speaking Switzerland, also a recent Apple TV user, and here it allows us to use points/periods in the French language version, even though we also normally use commas to separate whole numbers from decimal values in this part of the country.
(If Zwift were to recognise decimal points or commas as decimal separators in its API, this wouldn’t even be a problem…)

I’ve tried experimenting with the language of the Apple TV interface and also with the Zwift interface language, but have not found a situation that replicates yours.

Are any other Apple TV zwifters in France encountering the same thing as Lucien?

1 Like

@Lucien_Didot_FR
Here’s a possible workaround for you!
I assume that you have bought the latest version of Apple TV that comes with the Siri Remote.
When you navigate to the page for editing your weight, use the Siri button on the side of the remote to speak the values of your weight, saying “point” for the decimal separator.
It works best if you say each separate character, rather than saying the complete number. For example, in your situation, I’d say: “Six, quatre, point, neuf”, then click ‘done’.
It’s a bit slower than typing with the remote, but not much. I find the voice recognition pretty good. :ride_on:

I just tried it on my system in French. It successfully updated for me using the word “point”. When I used the word “virgule”, it faithfully produced a comma. Then, when I clicked ‘done’, I got the same error as you showed in your original post, with the comma disappearing. (I hope that the interface in France allows this workaround.)

By the way, if you use an iPhone, you can also call up a duplicate of the Siri TV remote in the Control Centre on your phone (swiping down from top right of any screen to show the possibilities), so you don’t even have to have the new, physical TV remote to do this.

@Anti-wtrl It’s depressing that a large number of people can’t even use all the letters of their language in the Zwift interface. It would surely be straightforward to recognise a slightly larger, standard character set in Zwift. When some people have all kinds of unusual graphic elements included in their identifier in the game, I just don’t get why something like ‘ø’ isn’t accepted. :confused:

2 Likes

@Roule_Thoune
Thank you for your feedback.
I changed Appel TV configuration with :

  • Unitied State location

  • English langage

  • Zwift in English

! Solution is working !
I think zwitf and appel don’t like French people :cold_sweat:

1 Like

@Roule_Thoune
yes, i bought the last version of Appel TV
I will try your second proposal

1 Like

@Roule_Thoune
Second solution with Siri is working on my side.

2 Likes

Hi @Lucien_Didot_FR

Thanks for bringing this issue to our attention!

It seems other helpful Zwift community members have provided you with some excellent workarounds, which is great to see.

That said, I’ve reached out to a higher technical authority on the team, and I’m checking to see if we have an existing localization request for this issue yet. Thanks again for letting us know!

1 Like

Hi @Lucien_Didot_FR

I heard back from the team, and confirmed that this is actually not so much a localization issue as it is more of a functionality issue. As things currently stand, the workarounds you’ve been provided are good ones to try, and it was suggested you might try using a period instead of a comma.

I’ve received assurances that we’ll get some attention on this, but it seems likely it will require some additional developmental work on our side. Thanks!

1 Like

Hello @Steven_D
Yes solutions proposed by @Roule_Thoune are working.
Thanks for your support and reached out to technical authorities.

Will be good if we can directly manage our weight with the same accuracy (0.1kg) on Companion.

I will continue to share proposal on Zwift improvement or Bug,
I have a lot of idea you can follow my posts :grin:
Ride on !
See you on Zwift.

1 Like