Wattage Freezes


(D Weinbeck ) #1

I have a cycleops Hammer, sometimes while riding on Zwift the Wattage and resistance will stay the same, it will show the frozen watts even when I stop peddling. Today it was stuck on 186. The only way to fix it is to unplug my trainer and pair it with Zwift. Has anyone else had this happen? It is frustrating, especially in a race.


(Chris Nackers) #2

my Hammer got stuck this morning, wouldn’t change resistance, had to unplug it and then plug it back in and once it’s repaired then it was working.


(Sean S.) #3

Sometimes, during workouts specifically, wattage will get stuck and you will stay at a steady wattage until you do something to fix it. We have a workaround that involves unpairing and repairing your trainer as follows:

  1. Stop moving.
  2. The menu button will show up in the bottom-left corner of the screen. Click it.
  3. Click the pairing button on the right-side of the menu.
  4. Unpair your trainer from both the Power and Controllable Trainer categories.
  5. Search for your trainer under both those categories again and pair them.

We also have an article on our knowledge base with more details here: https://support.zwift.com/en_us/wattage-gets-stuck-in-workout-mode-HJmXC1Wr7

If you continually have this issue, please open up a support conversation as we are still actively investigating this bug.


(Nigel Doyle) #4

Same. Hammer trainer. Happens occasionally. Seems to be an intermittent problem with the Hammer.


(Jan Tarnovski) #5

I have the same thing with Elite Drivo first generation (white). Wattage goes to 0 for couple of seconds and then returns back to last value and stays there. Funny thing is that cadence that is also coming from trainer is working. And also HR is showing. I’m using Zwift on OSX and Companion on iPhone and my trainer and HR are connected to phone.

But here is interesting thing I noticed. Since phone and PC are connected over WiFi and my router is pretty lousy sometimes communication stops for few secs. I think that confuses Zwift on PC and stops reading power and not only that it stops changing resistance when workout demands it. Tried turn trainer OFF then ON, closed (completely) Companion, turned bluetooth OFF then ON, turned WiFi on my PC OFF then ON even restarted router. Although restarting router helped first time it did not help second time. Naturally you cannot restart Zwift (as I’m in middle of workout) because I would have to start again and cannot exit workout as I haven’t finished.

And unpairing than pairing trainer did work and brought back power and cadence it froze back after few seconds


(Sally Bendigo) #6

I have had this happen whilst using my Hammer trainer. I never really know if it’s an internet issue or the trainer. I have power meter pedals so I know what power I’m doing but the screen will say 0 and my legs don’t appear to be moving. This is really annoying in a race or when I have been doing a big climb and I don’t want to lose the data ( which has happened-it didn’t appear in Zwift activities but did on Strava ). The only way that I have found to fix it is to unplug the trainer and plug it back in…and hope that the data continues from where I left off, and/or I can catch up again in the race. Does anyone else have any ideas on what might be going on? Thanks Sally


(Fez Rockbottom) #7

Yesterday during a workout on my Neo my heart rate monitor battery died during a recovery period but when the WO called for an increase in power the wattage was stuck no matter what I did. I jumped off the bike and put another HR monitor on, connected it to Zwift and then ramped up the power to re-engage ERG mode and things got back to normal. I failed the WO section :frowning: Maybe there is some connection between the HR and wattage being stuck though.


(G C) #8

I’m having the same issue, I have a CycleOps H2, wattage has stuck in workout mode twice now.


(Daniel Be) #9

I have the wattage freeze issue with the new Wahoo Kickr. Was riding the Three Sisters today and it got stuck several times. At the same time the wattage on my Wahoo Elemnt Bolt alternated as it should be.

Up one KOM Zwift froze at 251 Watts, while the Elemnt went up to 350 at the same time.

Not really fun this way!


(Daniel Be) #10

Happened again today… First Zwift did not even recognise the wattage I put on the pedal (my Elemnt did) and then it froze at the beginning, making me ride at 130 watts instead of 230 watts.

This really is annoying…


(D Zeno) #11

Same problem with a M2. Repairing does not resolve. Only full m2 power cycle. Problem started after last weks update. Makes Zwift useless. Should we be asking for pro-rating the subscription until this is fixed?


(Vincent W.) #12

Hey Daniel, have you tried troubleshooting pairing between your Kickr and Zwift? https://support.zwift.com/en_us/my-ant+-signal-is-dropping-(cycling)-SJdW01bHX

Also, can you send your log files to us via support conversation? https://support.zwift.com/contact/contact-us-HJH8N4RNQ


(Vincent W.) #13

Sorry to hear this @D_Zeno Can you send us a support conversation? https://support.zwift.com/contact/contact-us-HJH8N4RNQ


(D Weinbeck ) #14

Since I reported my Wattage freeze problem between my Hammer and Zwift, I haven’t had any more problems. I run a PC dedicated just for Zwift, it is hard wired to router and I have a ANT extension cord that puts the stick inches from my trainer. The only change that I made, I moved the ANT stick from right side to left side of trainer. I have no idea if it was the problem, but it has been rock solid for the last over one thousand miles.


(David Irvine (PCC)) #15

Same thing happened to me on Tour of London 15/12. Has happened a couple of times on Cyclops Magnus. Only happens in group rides or races - never in ordinary riding or workouts. I have to reboot the trainer and sometimes have to come right out of Zwift and go back in again. Very frustrating.

Trying to work out if I have companion on at the same time and that is causing issue but no solid evidence as yet.


(Neal Fleenor) #16

Same issue happened yesterday on my Cycle Ops Hammer riding the Tour of London #4 route. After about 4 miles into the ride, the wattage locked into 203 watts and stayed there no matter what actions I took (increasing/decreasing speed, shifting gears, powering hard uphill, unselecting/reselecting ergo mode, unselecting/reselecting the unit, and other combinations). Really was irritating having to pace uphill at a fixed wattage when I wanted to change the pace.


(Chris Wozniak) #17

Same thing happened 2 out of the last 3 rides in Workout mode. Running CycleOps Magnus with all firmware updated and calibration through Rouvy app because of that other spin down coordination known issue. Repairing in ride does not fix the issue for me, I need to shut down the program which is beyond annoying.

I am on month 2 of using zwift, and problems like this are unacceptable for people trying to maximize time. I used Rouvy before this and it was boring, but in two years never once had an issue in any workout ever. I feel like 25% of my rides i have issues with Zwift. About at my breaking point - this has obviously been an issue for months, yet no fix from Zwift. Not a good start for this new user.


(Greg Smith) #18

I have a Hammer and this happens to me about once every 10 rides. Only fix I know that works is cycle power on trainer. I don’t think the issue is on the trainer side as I haven’t seen it happen on Rouvy etc. But still an issue it appears.