Wahoo Kickr not showing cadence in Zwift

Got me a brand new Wahoo Kickr, got a Zwift account, did my first ride and noticed that there’sno casdence showing in zwift - but was showing in the Wahoo ios app. What do?

Miles, welcome to the forum! When you first log into Zwift, you’re at the device pairing screen. Make sure you’ve got your cadence sensor selected before you move on from this screen. Sometimes it’s helpful to go ahead and select the cadence device to unpair if a device is already paired, and pair it again. Hope this helps.

You should check to see if there is a firmware update for your Kickr, as the cadence option is relatively recent and was pushed out via an update. I’m guessing newly manufactured units already have the latest firmware, but it’s possible yours has been on the shelf for a bit. (A firmware update is always a good idea when first setting things up, though, as technology can change pretty quickly.)

Hi I have tried all that and still no cadence showing.