Updated Zwift and my Macbook (Catalina) and it won't launch

Hi there, I know this topic has been addressed before, but I haven’t been able to solve my problem with launching Zwift following any of the solutions offered. I have granted permissions, cleared + re-installed numerous times to no avail.
I attach a screenshot, for anyone caring to give me a hand.
*I had one last TdZ stage to go, damn!


Contact Zwift support

In the meantime what I would try is to delete Zwift. Reboot computer.

Download and install Zwift again.

Thanks for your contribution Guy, alas I have already tried all of that to no avail.
I contacted Zwift help, but they need to pass me on to tech dept.

For the update, instead of your WiFi or normal internet, try switching to your phone’s mobile hotspot. Or if you have a VPN, you can try that instead.

Hi Lin, thanks for your suggestion, I did try that too. No result. I even tried using another laptop (installed zwift and re-launched) I end up exactly the same.
Accidentally, on my iphone (same wifi - same provider) both zwift and zwift companion work.
I hope tech will solve this.

For this particular problem, you can’t compare the iPhone w/your MacBook. The iPhone does not update from Zwift servers, instead downloading from Apple servers. Also, the updates for your phone app or not just updates (i.e.,subset of changes or a patch) but instead the whole app w/changes. With your MacBook, it’s downloading a patch or partial set of changed files.

The reason I suggested using your iPhones hotspot to connect your laptop or connecting via VPN, is that it is possible that there is a cache issue on the the local Zwift CDN that your computer is trying to download the update from. By going to mobile data or VPN, you could get connected to a different CDN and successfully complete your download/update.

Thanks again Lin! I just pointed it out to show it isn’t a problem caused by my service provider. So, if I follow your logic it could be a problem with Zwift ‘s servers?