Update on 3-20-2015 caught in loop


(Jonathan Pait (X)) #1

Help! I wanted to ride on my trainer this afternoon and when I launched Zwift on my Mac the launcher appeared to get caught in an infinite loop. It went from Preparing To Update to Downloading to Updating over and over again with the same amount of time elapsing on the progress bar each time.

I then tried reinstalling from the .dmg file. Same thing happened.

I then moved all the prior application files into a folder named ‘Old’ and tried again. This time the launcher got stuck on Preparing To Update and moved no further.

After restoring the files I tried again with the same previous result. It is without a doubt an infinite loop. I could leave it running for days and it would keep doing this. What can I do?


(Jon Mayfield) #2

Sorry for the hassle. This seems to be a rare occurance but you’re one of the unlucky ones.

First, force quit Zwift.   Then, open a ticket up and attach Documents\Zwift\Launcher Log.txt and send that in.

Finally, to resolve the issue:

  1. Open up finder
  2. Hold the “option” key and click Go->Library
  3. Open “Application Support”
  4. Right click on the Zwift folder and move to trash.
  5. Re-run zwift from the mac launcher or spotlight