Update deletes game

Today I launched Zwift. It ran the auto update and when I hit “let’s go”… nothing.
Upon investigation, I see that ZwfitAppMetal has vanished from its normal location.
Tried to download and re-install. Still no binary.
Copied binary from another machine. “Let’s go” goes… until it crashes.
Launch Zwift on 2nd machine. It runs updates/patching and… The binary has now vanished from that machine, too.
OS (Mac, obviously.)
1 2018 Mac mini on Monterey
1 2021 MBP on Ventura

I fixed this… sort of
Downloaded Zwift for a different user on the machine. Copied the ZwiftApp binary over to my account.
Game updated again today and launched. Robo ride with Yumi went fine.
Group ride in Makuri, not so much. I was riding through rocks. Then riding through rocks alone.

I’m guessing that all Macs are on metal now, so they dropped “Metal” from the app name? I think I’d moved the non-metal variant out of the way to ensure use of the Metal variant early in the roll out. The installer/upgrader apparently wasn’t smart enough to put the new app there if the old one was missing.