Uncalibrating footpod

My Garmin footpod is more accurate than my treadmill. Zwift calibration is tied to treadmill. I hugely regret calibrating through Zwift (no fault of Zwift) because
“more deflating to see lower than actual pace” > “more ego-inflating to see higher than actual pace”
Now I’d like to uncalibrate–I want Zwift to forget the calibration. I’ve unpaired my footpod and re-paired, but it’s still calibrated to treadmill. Anyone able to uncalibrate?

@Justin_Farishon

For clarity on what you mean by “uncalibrating”: are you saying that you can not unpair the treadmill’s BLE signal from the game? As in - when you start the run session and you go to the pairing screen - does the Garmin run pod even show up as a run speed sensor? You should see both the the Garmin pod and the treadmill’s BLE signal. Is that not the case?

Or are you saying something else? As in - you’re paired to the Garmin pod, but the pace is off somehow? Please elaborate.

No, I have no trouble pairing footpod by BLE when in Zwift. (FWIW, I don’t see a treadmill BLE because my treadmill (ProForm) doesn’t have an open protocol). Garmin footpod shows up, I just don’t want it to calibrated by Zwift, which goes by treadmill speed. My treadmill is > .5mph slower than actual speed (yes, I’ve tried calibrating treadmill, but haven’t found a way to do that yet). I want Zwift to reflect my footpod’s calibration. The pace is off because it reflects what my treadmill says my pace is–but my treadmill is off substantially.

@Justin_Farishon
In general - you should calibrate using the manufacturer’s app. Those calibrations settings are stored in the device, not in the Zwift app.

Would you try calibrating with Garmin’s app and while you’re at it - check for firmware updates? Please fully charge (or change batteries) before you flash firmware so you don’t brick it.

Lastly, with runpods in general - placement matters for accurate readings. If you secure it to the laces as close to the toes as possible, it helps to stabilize the sensors.

Perhaps I’m not making my dilemma clear. My footpod is properly calibrated to my watch and manufacturer’s app–it accurately reads pace and distance on my watch (Forerunner 920xt). The problem is that Zwift–after a Zwift “calibration”–now believes that when my treadmill is set at 10.0 mph, that I am going 10.0 mph when in reality I am going 10.5 mph–which is what my watch shows. Before the Zwift calibration, Zwift believed that I was going 10.7mph–not perfect but closer to accurate than after calibration.

Justin,

If you are on a PC or Mac you can edit the prefs.xml file by right clicking and opening in Notepad or equivalent text editor (I’d make a copy before editing it in case your edits mess up the program). Based on the attached picture I believe you can just delete anything between < CALIBRATION > … < /CALIBRATION >


source: https://drive.google.com/file/d/1VREwCOoBbj-UtH3x1lowKdafUsgmDwOc/view

This is great! Thanks, Daniel! I’ve edited the .xml and will try it out. I also thought about it some more–another solution would be to do another calibration and have the speed display on watch. Then, I can set treadmill to whatever speed necessary (in my case, approximately (-.5 mph)) to achieve on watch display what Zwift is asking me for calibration.

Editing the .xml didn’t appear to have changed anything. So I calibrated by the alternative method I described above. I’ll see tomorrow if it works. On a side note, there was an option to delete the prior calibration. I presume that would have returned the settings to the prior status.

Alternative method worked. Zwift more accurately reflected pace per watch and not treadmill, though treadmill gets further from calibration as speed increases, so there is still a small disconnect at high speeds. But I’ll take it!

I am trying to do this on Apple TV, how would one do this on the preferences file there? Guessing uninstall and reinstall the Zwift App?