Ultra graphics profile as default for GTX 1650 Super

It is definitely ‘Ultra’ card, not ‘High’.

I agree with you, just got the same outcome. I fitted a similar card today (1650 OC) and ended up with it defaulting to HIGH, not ultra.

The 2 year old 1050Ti I took out was running at Ultra. Was a bit of a surprise, but the FPS rate was much improved.

Same thing happened when I got my 1660Ti a while back. Ridiculously, they have to do a profile for each card and what it can handle. They probably don’t have an Ultra profile for the 1650 Super yet. It’ll come, but it took them several months to add the profile for my 1660Ti.

I did change my settings manually in Zwift config files but many people unaware of the problem might be disappointed.

2nd’ed on this. I upgraded to an i7 / GTX 2060 / latest everything (software patches) / 4k screen / fresh install of Zwift. It defaulted to high. :frowning:

1 Like