No 4K settings with GTX 1650

Just upgraded my GPU from GTX 1050 to GTX 1650. But now I dont´t have any 4k mode in my settings only 1440p. What can I do to enable 4K?

This response from Jon Mayfield suggests it will auto-detect if Zwift thinks your machine is up to it:

It’s an old answer, so might not be the same now. Even with a great GPU, it’s possible your CPU could be a limiting factor.

If you want to try anyway, this article describes how to use a config file to specify your settings.

With my old GTX 1050 the 4k setting was enabled. Nvidia claims the GTX 1650 is 70% faster than the GTX 1050. My CPU i an I5-8400.

Thanks for the link about the tweak, will check it out.

Maybe it prioritises quality over resolution. It might be going for ultra graphics, so limiting the resolution. Because better lighting and shadows trumps higher resolution at lower quality. (Opinions may differ, and I’m only guessing.)

Looking at my latest logfile at zwiftanalyser it says 1440p HIGH, but in zwift i have chosen 1440p ULTRA… I do get an average of 87 FPS according to zwiftanalyser. It should be enough to run 4k Ultra.

Check out the Darren’s link to the ZwiftInsider post from Mike Hanney:

Zwift Config File Tweaks: 2019

ULTRA OVERRIDE FOR MEDIUM TO HIGH-END RADEON AND NVIDIA CARDS THAT DON’T GET ULTRA BY DEFAULT.

Edit basic.txt or high.txt depending on which profile Zwift gives you by default.

  • Highest world graphics resolution
  • Highest shadow resolution
  • High-quality lighting and shadows (gSSAO on)
  • High-quality reflections (default in High and Ultra, gSimpleReflections off)
  • Headlight On (default in High and Ultra)
  • 2 x normal auto-generated scenery (gFoliagePercent 200%)
  • High polygon count models (default in High and Ultra, gLODBias=0)

res 1920x1080(0x)
sres 2048x2048
set gSSAO=1
set gFXAA=1
set gSimpleReflections=0
set gSunRays=1
set gHeadlight=1
set gFoliagePercent=2
set gLODBias=0
set gShowFPS=1

It is debatable whether you will notice the difference of ultra res and sres on a 1080 display.

If you can’t tell, then revert the first two lines to:
res 1280x720(0x)sres 1024x1024

Experiment with gFoliagePercent to increase auto-generated scenery.

Stop increasing it when your FPS drops below what you are comfortable viewing.

ULTRA 1440 AND 4K RESOLUTION OPTION OVERRIDE

Do this if you have an ultra display but do not have the option in-game to select 1440 or 4K and are confident your GPU can run at the resolution you choose.

Edit prefs.config in %HOMEPATH%\Documents\Zwift\prefs.xml

Change the USER_RESOLUTION_PREF to your preferred display resolution

1440 WIDE QUAD HIGH DEFINITION (WQHD – 4 TIMES AS MANY PIXELS AS 720 HD)

<USER_RESOLUTION_PREF>2560x1440</USER_RESOLUTION_PREF>

2160 ULTRA HIGH DEFINITION (4K – 4 TIMES AS MANY PIXELS AS 1080 FHD)

<USER_RESOLUTION_PREF>3840×2160</USER_RESOLUTION_PREF>

Thanks for the link again. I have just finished a group ride on watopia flat with 318 riders in 4k Ultra, with the changes described above. Got 37 FPS average with my I5-8400, 8Gb ram and GTX 1650.

2 Likes

Are you still using the method listed above to turn on 4k for this card? I just reached out to Zwift support and received this response. Hoping they add it soon.

I took a peek at some benchmarks for the GTX 1650 and it does appear to be a likely candidate for 4k support. If Zwift isn’t allowing the option of selecting 4k then it’s possible this card hasn’t been evaluated yet. I’ve passed it on to the dev team, but we also encourage you to share your thoughts on our Community forums>

1 Like