Trying to Connect Lenovo tab4 plus

Has anyone had any luck using a Lenovo tab4 plus with zwift? I’m talking to support but they keep giving me the textbook answers.

I get to the connection screen and it just endlessly searches for my sensors without finding any of them. My PC finds them just fine, so I know it’s not my sensors.

I’ve tried using Zwift Companion, too, but my android app does not give me a way to change between using the device’s Bluetooth and ZC.

Allegedly this tablet is on zwift’s list of “runs ok” Android devices. But so far that’s garbage.

What are the sensors that you are trying to connect?

I have a Wahoo tickr and kickr, a Wahoo cadence sensor, and a zwift run pod. I use the first three for cycling and then the pod and tickr for running.

Did you make sure that all the sensors are not connected to any other device or app, including the Tab4 before opening the Zwift App? Bluetooth only allows one connection at a time to any device or app.

Going to ask @Gerrie_Delport to join in since he is an Android guy.

None of the sensors are connected directly to a device. I’m only trying to connect once I’m on the pairing screen.

You need to make sure to “forget” the sensors from your device. Go to settings see if you see the sensors in Currently connected and in Previously connected, if you see it select and Forget it. Also close all other apps before you open Zwift.

I’ve done that. It is still giving me the blank “searching” list, even though all of the devices are awake and discoverable.

And you checked that the sensors is not connected to your windows PC.

Yes. My PC can “find” the sensors, but they are not paired to the PC.

This is very strange. Did you try another app to test if the tab4 see the sensors.

I have not tried another cycling app as this is the only one I use. That said, the Tablet itself can find the devices–it shows them on the “available devices” tab under settings. So the tablet is finding them, just not in Zwift.

Hi @Haley_Brammer
Something that hasn’t been addressed yet: when’s the last time you updated the tablet’s Android operating system?

If you use the tablet to visit the Lenovo support site for that model, Lenovo can identify specifically which model you own, and check for any updates from their end.

I just got the tablet, so that shouldn’t be the issue. But I will check. It’s worth a shot.

Hey @Haley_Brammer
Something else occurred to me - you know how when you install Android apps and run them for the first time, nearly all of them will prompt you to grant / deny certain permissions: access your storage, location, phone, camera, etc?

If you disallow permissions to Location, you also deny access for that app to use the device’s Bluetooth radio per this old forum thread.

If you’re familiar with going into your tablet’s settings > General > Apps > Permissions menu and manually granting permissions to Locations, go ahead and try that. If you’re not comfortable with that, an easier way is to uninstall the Zwift game app, reinstall it, and then allowing permissions when you’re prompted during the first use.