Treadtracker Speed Not Registering

Is the TreadTracker able to be used for running on Zwift still?

I got one and it connects via bluetooth but my speed is always Zero. The TreadTracker shows up when searching for a speed sensor so I select it and start but I never move. The blue light on it stops flashing and it seems to be connected.

Hi @Jeffrey_Schulz
RunSocial’s Treadtracker is not on Zwift’s list of tested and approved devices. That said, the manufacturer touts that it broadcasts a Bluetooth Smart signal, so it sounds like it should be visible to the Zwift app.

What device are you using the run the Zwift app? What brand of hardware, and which operating system?

When your avatar doesn’t move, odds are the Bluetooth connection is getting interrupted. There’s other potential causes you may want to investigate here.

Please also ask RunSocial, the folks who manufacturer this sensor. I have no idea what the LED lights might indicate, so you’ll have to ask them. Is there a firmware update for it, perhaps?

Thank you for the reply, I tried using the PC App and the Phone App.

PC App on Windows 10:
image
It says it is connected:
image
image

I have a P30 Pro Android Phone, the phone app shows the same connected status.

When running it shows 0km/hr speed

I checked and the wheel is going around, but the speed is not recognized.

I watch this video and it seems like DC Rainmaker got it to work: https://www.youtube.com/watch?v=dQV5Dlvvwhg

Maybe my device is not working, I just got it from an online store.

I have an old Garmin Footpod but it very inaccurate, my speed goes up and down a lot even at the same pace. Unfortunatley at the moment my options are limited due to Covid 19 as I am in Australia. Might have to wait till all this over and hopefully I can get a Zwift Footpod.

Thanks once again.

Jeffrey, I have the same problem. Zwift see the TreadTracker and is connected to it (the Bluetooth LED changed from flashing to solid blue indicating it is connected) but, like yourself my treadmill is set to 10km/hr, I am running but my avatar is not moving. Very frustrating!

Mind you, if you use their software platform ‘RunSocial’; it works sweet! You know what this tells me is that they want to tight you in to RunSocial and pay for each virtual run that you want to gain access to. Not cool!!!

Hi Guys.
I’m also having the same problem. I’ve been using my tread-tracker on Zwift for the past 18 months or so with never any bother but now I cannot get the device to register any speed. The device looks to be connected when I start up Zwift but when I’m in game the device disappears from the connected device screen.
The tread-tracker appears to be on and all lights are coming on as normal, I’ve tried a few times to get it connected with no success.

Can you rest the tread-tracker? Or has there been a hardware failure?

Any help would be greatly appreciated

Thanks in advance.