Runspeed (Smart treadmill, Runn, Stryd, foot pod) will not connect/stay connected [1.39.0][May 2023] [SOLVED]

Bluetooth took over 12 minuets to connect , i was convinced it was completely broke and started run with it still trying and it eventually connected. Shut everything down , re started everything and exactly the same no connection. Before update it took seconds to connect.

1 Like

Can you give more detail. What TM is it and how are you running Zwift?

I have same bluetooth problem with my treadmill with this new update
before this update all connect correctly

for the moment I don’t find solution I trided to uninstall and install zwift but the problem is the same

I hope next update have solution to this problem

1 Like

Star trac treadmill with a gem modual plugged into the csafe port. I use a android device , in fact two devices and they both fail to connect . Allways worked perfect untill this update. The bluetooth connection is used.

1 Like

not sure if it’s related but I got the update today when I opened up Zwift on my Android devices (I use DEX to put it on a big screen). Couldn’t connect to my Runn device for Speed or Cadence. Connected normally to my watch for HR. Restarted everything and eventually gave up. First time I’ve had this in a few years of running with Zwift

1 Like

I have this same issue with the sole f80 treadmill

I did some tests today and the Runn module connects fine to the phone with the ConfigurEZ app. Just nothing shows up in Zwift. So something broke in the recent update

1 Like


Hi Shuji,

Are you in a position to confirm this is being looked at?

Multiple reports of devices no longer able to connect since 1.39 update.

I also contacted support and they forwarded the issue to the higher ups, I just reinstalled the app and same issue.

There was a similar issue to this a few releases ago so maybe it’s reappeared.

1 Like

@Gerrie_Delport_ODZ I’m wondering if these are all the same bug

It’s possible that treadmill users might be able to work around this bug by using the QZ app as a bridge to pair the device to Zwift ( / @Roberto_Viola). I have not tested this theory. I think the Sole F80 is supported by QZ.

1 Like

I get to work if I reinstall the application

Same problem here with the latest update and Runn with Android. Always worked fine previously, but takes ages or just fails to connect now. ConfigureEZ or a BLE Scanner find the Runn just fine, and Zwift worked fine until the last update. Have Zwift acknowledged that this is a (huge) problem yet?

1 Like

What are you running Zwift on Nikki?

I have a Runn using Ant+ to connect to my windows PC and it’s fine.

Are you using BT?

Uninstall and reinstalled, worked here so far. Easy fix, been years since i had to do that :slight_smile: .
Thanks for the info solution marked.

It doesn’t fix the problem beacuse next time opening up the application it will not pair the foot pod!

I can’t pair my Bowflex BXT226 treadmill anymore since the new update. It worked fine last week. Normally I have to open de JRNY app, connect the treadmill and in the programs menu tab run in Zwift. Than open Zwift, pair my treadmill there and of we go, but since the latest patch, Zwift can’t find my treadmill anymore. Went to Location on my device again and set the Location on Always when using the app. Still nothing.

I have a Galaxy Tab S7 FE.

I also noticed trouble with connecting my heart rate monitor. It paired the steps thing instantly. It saw the heart rate monitor but I was unable to connect. I unpaired the steps thing, but after that it couldn’t find it anymore.

guys with qz you can workaround this since qz can connect to your treadmill and then zwift will use the wahoo virtual device from qz that is wifi based instead of wifi

Let me know if you have any issues

Problem Solved. Reinstalled the Zwift app. It works. Me happy again. :slight_smile:

Since the new update, my Sole F80 treadmill isn’t listed in the devices when I try to connect it to the Zwift Game App.

I know my devices are working because my phone connects to the sole fitness app via bluetooth.

It just started happening with the newest update.