Runspeed (Smart treadmill, Runn, Stryd, foot pod) will not connect/stay connected [1.39.0][May 2023] [SOLVED]

Hi @RobImpala, I notice users reporting a workaround to this issue by reinstalling Zwift. Have you tried that yet? And if so, did it resolve your issue?

Although you mentioned your treadmill, you didn’t mention how you are running Zwift. Are you running Zwift on an Android device?

Hi @matthew_close, thanks for being the first to mention reinstalling Zwift resolved your issue. It’s not clear if this second post means reinstalling didn’t actually work or if this is a separate issue.

Please note: Zwift saves off whatever device was used last. So if you were at a gym or something and used a different device there, then returned home, Zwift will still be remembering that other device even though it isn’t present. In such a situation, if you select your normal hardware and begin an activity, you should find Zwift will have saved the selected device for next time. If not, please reply with details.

Disclaimer for others reading this post: Zwift remembers the devices used in the last session and can automatically re-connect on the next session. There are some caveats though. Specifically for Cycling sport there is an exception for Controllable Trainer device. Zwift can remember the last used Controllable Trainer device, but at the present (May 2023) cannot auto-connect to the device if a different device is being used for Power.

1 Like

Hi Mike

Once the zwift application is reinstalled on android, zwift detects NPE runn directly.
But once the application is turned off, it no longer detects runn
that’s why some users have said it works.
uninstall and install zwift every time before running on zwift

Ouch. Thanks for the clarification @NO_PAIN_NO_GAIN.

This sound line a bluetooth permission issue.

When you reinstall Zwift and it ask for permissions try selecting this time only, then every time you open Zwift it will ask for permission and then select this time only.

I have been having a similar issue on my android devices since the update. My Polar bluetooth footpod is no longer recognised by my android devices (I recently updagraded phone so I was able to check on two devices). I know the footpod is still working as it was able to pair successfully with my Ipad and Laptop on the zwift app. I generally don’t take my ipad to the gym so I rely on my phone while running on a treadmill using zwift.

No it didnt fix, next time used will not connect. Have to re install to get it to work once .

1 Like


It works the first time to connect then you have to reinstall and install again to workout again.

I am using Zwift on an Android OnePlus 7 device and a Sole F80 Treadmill.

Both have worked flawlessly until the last update. Over 700-800 miles ran with the setup.

@RobImpala @keith_Trivett

Did you try the suggestion I made above. " permission and then select this time only"

not other permission

I just put back NPE Runn zwift application and by miracle it works :thinking: :crazy_face:
I hope to have no more problems.
thank you for your help

When on Zwift - when to ride selection and then back to Run then it connects to my polar foot pod. It works:)

If that happen again go to your android settings under (Permission manager - Location - Zwift) and change it to “Ask every time”

If this works then you can try to set it to “Only while using the app” and test again.

I’m don’t think this is a permissions issue; all my phone permissions have been left the same compared to the 1.34 and 1.39 installs.

Opening the app for the first time won’t connect my runpod via bluetooth (won’t connect automatically, nor will the pod appear in device search); but hitting “skip”, and either going into the pairing screen or hitting the exit and reselecting my account will pick up the pod and connect.

Seems to be fairly consistent to reproduce each time I force close the app and then reopen it.

1 Like

I just finished a run and Zwift worked. I restarted my treadmill and phone to test if I was able to connect again without reinstalling the app.

It wouldn’t connect at first, but then I tried what Colin suggested

And it works after that. I guess as long as I can use the app its fine with me, but its definitely something on Zwifts end and not my permissions if me and Colin have the same exact problems

1 Like

Just to add something else, I think it has something to do with the app defaulting to biking instead of whatever you used last. Before the last update it always defaulted to running for me and my treadmill was found before i even searched for it, now it defaults to biking no matter what I exercised last

Ok look like Colins work around works for me , if i skip and get to the selection screen then go back to the connection page treadmill comes straight up. Nothing to do with permissions imho.

2 days after my last post. Wanted to run again. Problem is back.

has this issue been acknowledged by Zwift yet? There’s three or more threads on this making it sound like running is largely broken (is it just on Android?) but no mention of any problems in the 1.39 known issues thread

I reinstalled Zwift again on my Android Device. Within a few seconds it found my treadmill again.

Since the latest update, [Game Update 1.39 [May 2023], my stryd pod will not connect to zwift. It does not connect to any device. I’ve tried two android phones, an iphone, and my pc. None of those work. I thought I might be having an issue with my stryd pod, but it connects fine to my Garmin watch without any problems with both bluetooth and ant+. The stryd pod will also connect to my phone in the styrd app using bluetooth. The stryd pod is fully updated, the only change is the latest game update, 1.39.

Has anyone else had this issue?