We have just bought one of the last tread trackers (as they are now discontinued) having had endless problems with the runpods - not pairing, awful speed recognition, not even working at low speeds etc - and can’t get it to pair in zwift at all, it’s on and working and the other half has had it paired in the runsocial app so it is clearly working.

We have tried all pc and Android set ups possible in our house -
Windows 10 laptop, windows 10 PC, both with native Bluetooth and via the ZCA (via android on an honor 10 or a Sony xz compact)
Also through Android full zwift app on both of those phones. Nothing.

Incredibly frustrating! Please help?!

Thanks in advance

Did you get it to work?

Hi Jeffrey - no we didn’t get it to work. After a lot of back and forth with zwift/treadtracker/the company we bought it from we discovered it was v1 TT which was never capable of working with zwift. The company acknowledged that it misrepresented the product (supposedly by accident - who knows!) and gave us a refund. So, stuck in this lockdown with no way for me to zwift on the treadmill as the pods just don’t work with me - my stride rate is too slow/irregular and i ‘run’ at too slow of a pace. Heyho. Lots of gardening instead.

That sucks, I just got a tread tracker as I have the same issue with my foot pod. The speed is all over the place. If I walk it says I am walking very slow 4km/hr when my treadmill says 8km/hr and I am walking as fast as I can. Run Social wont find the Tread Tracker at all and Zwift finds it and connects but does not get the speed data. I tried the Windows Zwift app and Android App and Run Social Android App. Maybe I will need to return it to the shop and say it doesn’t work.

I definitely recommend firing an email to runsocial, they were super helpful with me even though it worked fine with runsocial and it was zwift that was the issue