Training Plan (Build Me Up) not capturing workouts after completion?

Same here, on an Apple TV, latest Zwift App (1.0.63185). No problem before this update.
And I confirm the last post, once exported to Strava, the “Build me up-” part is missing in the title.

Edit : a new release today (1.0.63186). To be tested at the next WO.

Thank you I have the same issue and you have spotted a discrepancy. My last two rides in week 5 have not registered, Tine and Escalation. I have not had this problem for the first 4 weeks of the plan and I can confirm that the rides in Strava and Garmin Connect show only the name Tine and Escalation. All the previous workouts show Build Me Up - “Name of workout”.

I am running on an iPad and believe this started after the latest Zwift uodate

1 Like

Same issue here. On round 2 of Build Me Up… worked flawlessly first time around but now not attributing completed sessions to the plan. Recorded in Strava as only the ride name without the “Build Me Up” association. Seems to be linked to latest update.

Same problem with my last two workouts in week 6 of Build Me Up plan…completed all the stars but the training plan is not being updated…having to manually tick the ‘I did this’ to update the plan…very frustrating

2 of my workouts in Week 7 Build Me Up (Spaded Sweetie and Kirizuma) shown deadlines. I have finished them prior to Cucumber, but now Cucumber all gone from the Week 7 list and these two still need to be done. Oh so tiring. I have all the record in Strava though. What should I do?

I’ve got the same issue as others - with the build me up plan. No longer registering complete activity. If I click ‘I’ve done it’ it says I’ve done it outside. No credit applied. Sure it doesn’t really matter overall, but still, feels slightly being cheated of the effort…

5 Likes

Same issue here. On week 9 of the programme and up until now was smooth sailing. Past couple of days, activity isn’t saving, programme isn’t updating, and the latest workout (bricolage) completely disappeared from Companion app after completing it this morning. Bit annoying really considering it was a 2 hour ride…

1 Like

Just had the same issue on Bricolage…week 8 of the Build Me Up Training Plan. Did it have to be the 2 hour ride that goes missing :man_facepalming:. Completed ride and it uploaded fine to Strava and Training Peaks but then disappeared altogether from the Zwift Companion App. Logged into Zwift and it’s there as not done and do by tomorrow evening :-(. Apple TV 4K so seems to be platform independent based on other people’s experience. I’m not doing the 2 hour one again :-).

1 Like

Am having same issue on week 2 of Build Me Up. Completed both Mishmash and Orange Unicorn. They are showing as incomplete on Zwift app. Am using iPhone XR.

Same here —

Happening with “Build Me Up” Week 2

I’ve completed “What goes up, must come down” and “Halvfems” and they show as completed on Strava, but just the name of the workout without the Build Me Up part in the title, and in the training program schedule it still shows these workouts are either expired or still due, despite completing them

Using a Wahoo Kickr Core and an iPad

Seems like this is a well documented problem by now

Same here. Build Me Up, week 1. Completed Devedset and Red Unicorn, can see both in the companion app and Strava. I noticed the issue after the due date so I haven’t been able to manually click, “I did this.”
Week 1 on the training plan now just has two activities, pedaling drills and benchmarking.
I know that regardless I am putting in the work and improving, but it would be nice not to have to deal with these little issues.

This didn’t work for me sadly… I clicked the “I did it button” and it ticks it but you don’t get any of the stars etc… I guess the main thing is i know I did it even if the game doesnt credit me :slight_smile:

Thats how it is supposed to work, you don’t get any stars when using the “i did it” button

I’ll add my name to this too! I’ve just finished week 11 of Build Me Up, it’s worked flawlessly until the first of this week’s two updates (I use my iPad) and ever since won’t register that I’ve completed the workouts on the plan. I also noticed the rides don’t include “Build Me Up” in the name.

I’ve raised the issue when support and sent a few screenshots of the issue, plus they also asked for log files to be sent to them. If I get anywhere I’ll update here.

6 Likes

Thanks Mike, that’s what I thought but saw the post above that said:-

Workaround:
You can click “I did this workout” the next time you check the training plan progress bar, and you will get full credit.

We are investigating this issue for resolution in an upcoming release.

I took “full credit” as meaning it would recover them somehow. Didn’t believe it, but tried it anyway :-). As it is possibly a bug, in this instance I wondered if it would work but alas… Cheers :slight_smile:

Same issue. Very annoying!

Same issue here - some people have said don’t use two devices but I have my iPad showing in game and iPhone showing wattage dial to make sure I can see the zone better - very annoying as I don’t really want to hit I did it every time - that’s a band aid - not a solution

Same problem described above. See the workout in the training plan, do the workout, saves to Zwift and Strava as an activity without the "Build Me Up - " prefix, but no registration of the workout in the plan. Using Apple TV 4k. Started with Week 8 Bricolage has continued into Week 9. Check ‘I did it’, got credit, then next day it’s not listed in the training plan. I’ll keep going with the plan, but it would be much nicer if it worked as it has for 2 months…without issue. Apple tvOS version 14.4. Zwift version 1.10.1(63586). Looking forward to a fix…

Same issue today with Giza session