Training Peaks workouts went away [Nov 2022] [1.31] [SOLVED]

UPDATE November 11
We are still working on this bug, and it did not make it into the v1.31.1 patch for PC / Mac that went live a short time ago.

Please bookmark this thread for progress reports. Thanks for your patience.

3 Likes

Would this work on Mac Os?
If yes, can you point me to some instructions please?

11/14 around 7am US Eastern - Windows 10. Got up to ride. the TP workout was in my list - Great - I thought.
I selected the TP workout.
When I started, all of the segments in the workout were configured as “Free ride”, and occasionally I would see a message like “RPE 2” in the middle of the screen.

So while the TP workout segments were there, and the time of the segments was correct, there was no ERG at all.

I also tried this same TP workout on my Android device and noticed the same thing. Everything as Free Ride/no ERG.

11/15 around 5:30am US Eastern - Windows 10. Seems to be fixed - had a successful workout this morning using a TP workout.

11/15 about 7am US Easter - Windows 10.
After seeing David’s note, I was hopeful, however my TP workout seems to be same. No ERG mode - everything is “Free Ride”.

Here is the screenshot from my ride. I also unlinked and relinked my TP from Zwift when troubleshooting the other day. that may have made a difference. I used the companion app during workouts as well.

Trainingpeaks workouts are not pulling though to Zwift. It only started this morning, last worked on Sunday.
I have disconnected and re-linked TP, but still no success.
Anyone else have a similar issue that was resolved?

Mine is on iOS (phone & tablet).
What I did eventually work out is the following:

  1. Open app - see if custom TP workout is there.
  2. If not - close app with close button on top right of screen. It will return to login screen.
  3. Log in again and navigate to Custom Workouts. It is likely to show up now.

FWIW, I had no issue this morning running a TP workout from my IPhone.

Any update on this, it’s been quite a while now?

Sill working on this one.

There are two way to import data from Training Peaks.

After you prepared a set in trainings peaks.

Methode 1:
Press the export and select Zwift format. In this case the session appears on Zwift only on the date of Training Peaks calendar.

Methode 2:
Press the export and select Zwift format. If you want the set permanently available in Zwift, locate the exported file within you download folder and copy the file manually to the Zwift log folder.

UPDATE Dec 5

A fix has been identified and will be in this week’s game release. Thanks for your patience!

2 Likes

I’m planning on doing my first TP planned workout in a long while tonight (AppleTV) but just saw this post. I logged into AppleTV and see the planned workout is there but am wondering if it’s going to work (just trying to avoid some possible late night frustrations). It’s not clear from the posts above which problem the “fix” is for.

@B_Jimmy
Not yet. The fix will be released later this week.

1 Like

UPDATE December 2
This bug’s been fixed in Zwift game version 1.32.0, which just released. Please update at your earliest convenience.

just updated to version 1.32 Training Peaks still is missing, where is a problem?

Hi @Vladimiras_Jakovleva welcome to Zwift forums.
Shuji at Zwift HQ here.

I looked at your server logs and I’m seeing you logged into Zwift on an iPhone14 and a PC at the same time. When you have two or more devices logged in at the same time, it creates weird problems, and it’s possible that not syncing to to third party services like Training Peaks / Today’s Plan / etc. is one of them.

Use only one device to run the Zwift game app. If you want to be certain to avoid any problems, uninstall the game app from any other devices. Would you let us know if that solves your sync problem?

Hi, thanks for answer, strange but yesterday TP workout worked as expected, so no more problem here.

When it works it works fine on both devices without any problems :slight_smile:

Thanks for helping.